setting up openMRS 3.0 server

I get a build failure when setting up O3 server. How can I resolve this?

@reganmakanga Do you have a good internet connection ?

@tendomart , I think it’s good and stable sometimes because I was able to set up reference application 2.12.2. could that be the only reason I get a build failure?

1 Like

You used an alpha 3.0.1-SNAPSHOT-alpha version with choice 1.

Try using Reference Application 3.0.0-SNAPSHOT with option 2 and let us know what you get.

alpha releases usually have issues, and are not intended for production

I tried option 2 and still got a build failure. Have a look at it here Microsoft Windows [Version 10.0.18363.628](c) 2019 Microsoft Corporation. All - Pastebin.com

hello i have the same problem

There is no functional 3.x package which can setup a version of 3.x from the SDK Setup command.

1 Like

What can i do solve it

okay. Thank you @ibacher

@nyyesigahenry and @reganmakanga kindly select the 3rd option.(Reference Application 2.12.2)

1 Like

Thank you @jwnasambu . It’s up and running

hello i have tried 3rd option it has also failed but it has allowed me reach some steps

reganmakanga me it has failed

install JDK set up maven set up mysql server Then set up openmrs SDK by running mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:setup-sdk

after that you will set up server

@nyyesigahenry Kindly let me know if you are available for a sync

hello available now

@nyyesigahenry Oh sorry! are you still available? I only have 10min.