Sdk setup on windows

Hey @wikumc i have been trying to setup the sdk on windows and it seems to lag at this stage (as seen in the screenshot below)

I have set it up before on this machine but it seems to be having an issue at that stage. Could there be something i am doing wrong? cc: @dkayiwa

1 Like

Could you provide more details regarding the specific step where you’re experiencing a delay?

  1. Is the delay occurring during:
  • Scanning for projects
  • Setting up a new server
  • After specifying the server id
  1. Can you specify the duration of the delay you’re encountering?

Additionally, it would be helpful if you could share your PC specifications with us.

setting up a new server (as can be seen in the screenshot above)., after specifying the serverId and hit Enter, i lags and thats where it stops.

can’t really specify the duration since it never goes beyond that step. It just lags.

Please note that i have been running a server recently on this very machine and i wanted to set up a new one since i am trying to reproduce some issues on the fhir module reported by Mark.

@mherman22 have you tried the default server "Server name …" without specifying anyother name

yes i have. I have even used the default option but it has failed to go beyond that step

It works without a delay for me but I’ll take a look at what might causing the issue.

First try to

terminate all running ports and restart

Check here on how to do so then try again …also

check the maven you are running

Otherwise on Ubuntu so far seems fine

Also try to specify everything within the command like

mvn openmrs-sdk:setup -DserverId=server1


mvn openmrs-sdk:setup -DserverId=server1 -Ddistro=referenceapplication:2.12.2

and see what happens

@mherman22 what your output for mvn -v?

this actually helps, thanks @jonathan

Apache Maven 3.9.4 (dfbb324ad4a7c8fb0bf182e6d91b0ae20e3d2dd9)
Maven home: C:\Program Files\apache-maven-3.9.4
Java version: 1.8.0_202, vendor: Oracle Corporation, runtime: C:\Program Files\Java\jdk1.8.0_202\jre
Default locale: en_US, platform encoding: Cp1252
OS name: "windows 10", version: "10.0", arch: "amd64", family: "windows"

Is it running without any other lags with this command?

mvn openmrs-sdk:setup -DserverId=server

yes it does.

Though am still wondering why it lags when I don’t explicitly state the serverId using -DserverId

@wikumc this might need a look through though

Sure, I’ll take a look at this.

1 Like

this seemed to work until the point i had to choose a port, it lagged again and unfortunately under the setup command, we cant use something like -Dport=xxxx so that i can just add that into something like mvn openmrs-sdk:setup -DserverId=server -Dport=xxxx.

I went ahead and did some digging and realised that when i run mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:4.0.1:setup, which specifies the sdk version to run, the lagging stuff never happen at all and i go through the steps as should be and the server is created successfully.

hope that helps @wikumc

1 Like

oh thanks @mherman22

however the option here u can specify something like

mvn openmrs-sdk:setup -DserverId=server -Ddistro=referenceapplication:2.12.2 -DbatchAnswers="8080,1044,MySQL 5.6"

using -DbatchAnswers


hello @mherman22 did you try to increase your mvn storage using MAVEN_OPTS environment variable to 512Mb

Can you check with the version 5.4.0?

I wasn’t able to recreate this issue on Ubuntu. Do we know if any one else is having this issue on Windows?

I do, but I don’t know what the problem could be but I think I should switch to Ubuntu! Do you have any experience with WSL @wikumc @jonathan ?