SDK Release 4.0.0

Hi everyone,

Just a quick announcement that I’ve released SDK version 4.0.0 this weekend. It has no real new features, but rather has had any functionality that was reliant on Bintray ripped out. Hopefully, the new version still works for most of the use-cases everyone has. As part of this, the openmrs-sdk:release functionality has been removed, as this primarily released an artefact to Bintray.

If there are any issues or errors, please either report them via Jira or this thread.

In the next little while, I’m hoping to upgrade the SDK dependencies to work better with modern versions of Java.


thanks @ibacher :+1:

Thanks so much @ibacher! :100:

Cc @frederic.deniger :point_up:

well done @ibacher

Thanks for the Load @ibacher

One other change I should’ve mentioned: the openmrs-sdk by default installs a settings.xml file to configure your Maven instance. This is usually installed in ~/.m2/settings.xml (for *NIX based computers) and C:\Users<username>.m2\settings.xml (for Windows). Inside this file, there are a couple of references to the openmrs-bintray-repo. If you’ve manually edited your settings.xml file, you should manually remove those entries. If you haven’t manually edited your settings.xml file, you can delete it via either rm ~/.m2/settings.xml (*NIX) or del %USERPROFILE%\.m2\settings.xml (Windows) and re-create the standard one by running mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:setup-sdk.


@ibacher Excellent that the SDK is finally getting some love, if you could help out IMO there is an SDK needs to using cached resources otherwise each SDK build has to hit the internet, so basically it does not work offline which also fixes

Thanks in advance

@ssmusoke - not sure if you saw my comment on SDK-239 from around a month ago, but that issue I would expect to now be solved as we have transitioned off of bintray and all OWAs are now coming from maven. It would be great if you could test that now and close that ticket out as fixed if you feel that it has been addressed to your satisfaction.

I would expect everything to work offline by connecting to the local .m2 directory for all artifacts as needed, whether those be war, omod, or owa. If that’s not working as expected, let’s detail it out so that it can be investigated. Are there specific commands that you are trying to run which are only able to succeed if you have connectivity to internet? Can you detail those out on the tickets or here?

Thanks! Mike

1 Like

Thanks @mseaton let me upgrade and test it now - I had not seen any comments on SDK-241

@mseaton @ibacher Excellent work, now I can use the SDK without an Internet connection - :dancer:t6:

I am not sure what commit to reference SDK-241 to close it as fixed maybe you can help with that

Somewhere in this mess although @mseaton’s commit for SDK-271 is also relevant.

@ibacher I will do the wild thing, close both tickets as fixed with the same commit

Tbf, I had completely forgotten about that ticket while working on this, so it was fixed by mistake.

@ibacher magic code fixes issues by mistake

Also seems that there is no upgrade path from 3.3 to 4.0.0 a new installation is required after deleting settings.xml - can I go ahead and add that to the documentation

Yes, that’s reasonable, but unfortunate. Maybe something for a 4.1 release.

1 Like

Does anyone run into this issue setting up the 4.x version of the SDK I keep getting this error

[ERROR] Failed to execute goal org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:4.0.1:setup-sdk (default-cli) on project standalone-pom: Execution default-cli of goal org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:4.0.1:setup-sdk failed: Plugin org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:4.0.1 or one of its dependencies could not be resolved: Could not find artifact com.atlassian.jira:jira-rest-java-client:jar:2.0.0-m2 in central ( -> [Help 1]

I have ever faced the same problem and this is how I sorted out. I run the following commands

del C:\Users\DELL\.m2\settings.xml
mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:4.0.0:setup-sdk

To fix the issue related to Maven 3.8.1 not liking http links for repositories. Since the version of settings.xml bundled with SDK 4.0.0 changes all our http links to https . then followed by this command

mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:setup-sdk -U

@jwnasambu Thanks for this I am using Maven 3.3.9 which has been stable, do I need to upgrade that too?

The issue persists with Maven 3.8.1 too

Concerning upgrading mvn I believe @ibacher can be of help. I didn’t upgrade my mvn version since it was a fresh installation to set up an sdk instance. Thought mine is version 3.5.3.