sdk cannot sart!!


(Herbert Yiga) #1

Heilo, i am trying to start up sdk.But i removed de-saumya-mojo-gem-maven plugin from my pom of the reference application since mvn clean install couldn’t build,after the build passed successfully and i deployed the .omod to my sdk,on running mvn openmrs-sdk:run ,openmrs starts but with this interface and these are the logs. https://pastebin.com/anEpFmwZ

any one with a clue on this? @dkayiwa @ssmusoke @k.joseph @ruhanga


(Nathan Ruhanga) #2

@herbert24, can you uninstall the referenceApplication module by deleting the its .omod file from the modules folder and then try uploading it from the administration page then restarting all the installed modules. You should be running reference-application-distribution instance of openmrs because it’s bundled up with most of the modules that are depended on.


(Herbert Yiga) #3

i tried this process but unfortunately it did not work out!!!


(Irene Nyakate) #4

After deleting the files you may need to restart your machine.


(Herbert Yiga) #5

true i did that but still got the same error


(Irene Nyakate) #6

which RA version are you building?


(Herbert Yiga) #7

version 2.9


(Irene Nyakate) #8

Are you trying to test something? Because RA 2.9 is not yet released.


(Herbert Yiga) #9

i am working on a ticket though i directly used 2.9 snapshot


(Herbert Yiga) #10

I thinks let me first try out on using stable version


(Irene Nyakate) #11

oh ok, now that it is just a SNAPSHOT version do you think the UI is better than that? I am just thinking it may be at that level since it’s a SNAPSHOT the UI may be still not like the stable version yet.


(Herbert Yiga) #12

aright let me get here after trying out on another version


(Juliet Wamalwa) #13

That version is not yet out just stick on 2.8.0 till it is released.


(Herbert Yiga) #14

okie thanks