Running Ozone FOSS in Gitpod

Hi everyone, we are working hard to ensure that you can quickly spin up the demo of Ozone FOSS on any environment but we are still facing a few challenges due to environmental peculiarities.

We continue work on trying to resolve these issues and in the meantime we have introduced an Open in Gitpod button (:point_left: This button works try it :wink: ) in the Ozone FOSS Docker Compose project to ensure everyone (with a Gitpod account) can quickly spin up Ozone FOSS reliably for testing.

Note To access Ozone on Gitpod please check for the links in the ports tab at the bottom of the window.

4 Likes

Thanks @achachiez this helps alot.

Feeedback

Please how do we access the Ozone SPA from here - ok thanks, we add /spa to the end of the url… but i dont think it deployed yet cos it not working yet but every other thing works except senaite…the login credentials are not work and css looks off

  • For Openmrs3, if the url ends in “spahome”, change it to “spa/home”

  • For Senaite, use the username/password: admin/Admin123. To get the css to load, you will need to allow ‘mixed-content’ on the browser. Use the suggestion described here to get the css to work: http - How to get Chrome to allow mixed content? - Stack Overflow

Many thanks for this. Will do…here’s wishing you and your team a very happy and great new year ahead!

Many Thanks @zotis ,

Allow ‘mixed-content’ worked for the css issue on Senaite but the password still now work, i tried admin/admin no joy…also tried admin/Admin123 . still no joy. But i’ll keep trying and will revert on success.

spahome to spa/home also worked!

update - the password is ‘password’ found it in the .env file . Thanks!

Wonderful! At least I can run Odoo, Superset and Ozone . Senaite’s html isn’t rendering well for me but I will keep trying. Great work

thanks

Lawrence

See Running Ozone FOSS in Gitpod - #3 by zotis above

2 Likes

@zotis the default credentials for SENAITE are admin / password as can be seen here.

Sorry about the confusion, I will update the docs right away…

Cc @enochb :point_up: since you had issue logging into SENAITE in Gitpod.

2 Likes