Running openmrs-esm-patient-chart locally

hello @everyone Am trying to work on “openmrs-esm-patient-chart” but am incurring an error when I run it locally Can anyone assist me on how I can resolve it

Hi @kalemeeracollis !

do you faced any issue in the terminal. if so may you can paste here and share


hi @vijaykv here openmrs-esm-patient-chart - is the output f the terminal

@kalemeeracollis I hope this may work :

  • Make sure your fork up to date? git pull upstream main --rebase

  • If it’s up to date, try deleting the dist and node_modules folder and re-run the package again after doing a yarn install

After above steps try to run it

yarn start --source 'packages/esm-<which_you_want_to_run>-app'

1 Like

Thanks @vijaykv but i had tried all that stuff and it refused ressolve the error

Have you checked your browser console for any errors?

Here is what is displayed in the browser console error3

Is there anything before that? Warnings? Etc.

Hello @ibacher when i run yarn start on loading to the browser it first pops this error message

The best I can guess is that there’s some sort of network error. The errors are ignorable, but annoying.