Running Bahmni on Docker: /etc/bahmni-installer/local: No such file or directory

docker
Tags: #<Tag:0x00007f23dedcfad8>

(Vignesh S) #1

Hello,

I am unable to setup Bahmni using Docker.

When I run sudo ./docker.sh , it complains /etc/bahmni-installer/local: No such file or directory. But I did confirm that it exists and also I tried copying the content of the aws_qa03 file to it.

The container is up and running. When I enter the container and do curl http://localhost , it complains

curl: (7) Failed to connect to ::1: Cannot assign requested address.

I use Ubuntu 16.04.5 LTS.

Thanks


(sanjeev kumar) #2

add below line in DockerFile

RUN mkdir /opt/bahmni-installer


(Shilpa Parab) #3

Hi @vigneshsekar,

Hope you have followed this wiki bahmni docker link: https://bahmni.atlassian.net/wiki/spaces/BAH/pages/299630726/Running+Bahmni+on+Docker

As per this documentation, the line RUN wget -O /etc/bahmni-installer/local https://raw.githubusercontent.com/Bahmni/bahmni-tw-playbooks/master/inventories/$inventory_name needs to be removed.

Please download the local inventory file from the repo https://github.com/Bahmni/bahmni-playbooks/blob/master/local and put it in directory from where you are running docker.sh

Please include below line

ADD local /etc/bahmni-installer/local

ADD install_bahmni.sh /tmp/install_bahmni.sh

RUN chmod a+x /tmp/install_bahmni.sh

Hope this resolves the issue. Thanks.