Revert Distro 1.8.O-SNAPSHOT TO 1.7.0-SNAPSHOT.

There were some preparing.refapp.distro.release varible value switching caused trigger errors at

This is blocking release of RefApp 2.7 Can the Distro pom.xml versions be Reverted from 1.8.O-SNAPSHOT to 1.7.0-SNAPSHOT ?

cc.@raff cc.@dkayiwa FYI @ssmusoke

1 Like

@tendomart, I will take care of running the release from CI. I’m waiting for a new SDK version to be available to complete the release. I should be able to do it tomorrow.

@raff Thanks alot. So was there any other problem,other than the switching of the variables?


It appears to me that the release to maven worked fine (with both the git tag and maven artefacts pushed).

What broke was updating the refapp distro pom file with the released version of this module. If you just edit the refapp, you can consider it a success.

In order to rerelease, it would be much more complicated and with side effects for every machine which downloaded 1.7.0, include build agents. It’s not really recommended.

1 Like

@cintiadr Thanks for the diagnosis,do you then mean manually editing Distro pom.xml Reference Application-module version to 1.7.0 ? And what about and the source forge.Would they be in sync?

I tried checking out the Module Versions but they had not yet been updated to their RefApp 2.7.0 counterparts.

@tendomart, there was an additional issue with SDK failing on building a SNAPSHOT version after a release.

@cintiadr, even though publishing to maven succeeded, there were a number of steps, which didn’t run due to failure with updating the refapp distro pom. I tweaked the plan to separate out as many jobs as possible so they can be corrected and re-run individually.

I know it’s not recommended, but I did delete maven artifacts and let the fixed plan push them again. They are logically the same so there shouldn’t be any issues.

@tendomart, succeeded. You can proceed with the remaining steps.

1 Like

@raff wow thanks’alot that’s the best news so far this week.

Thanks @raff much appreciated

Hallo Cintia,i recieved the priviledges to edit the blog post, i however cannot edit page to include the latest download links,can you help accord me the privileges please.Thanks alot

Regards Tendo.

You can make them deployment environments if you prefer, shouldn’t cause any drama.

Raise a ticket for that, I think it’s on the instructions, right? To update the pages and stuff.

@cintiadr is it necessary to create a ticket at this time,since i want to announce release a few moments from now?Am asking because i thought you have the right to grant me that privilege.

@raff should the be automatically or manually edited cc. here

Manually as stated in instructions:

Create a new case at OpenMRS helpdesk requesting to update, the home page and downloads page to the latest release. Please provide links to the downloads. DO NOT mark the Impact of your case as anything other than Routine.

I’ll do that for you.

@raff Thanks. Am i not allowed to do it?

however the Blog Post is already up.

No, you need to create a helpdesk case. It requires higher privileges to edit that page. Anyway, I’ve edited it already.

1 Like

Alright thanks alot,i had however earlier created it with a pending response.

Thanks @tendomart! It seems like RA 2.7.0 is officially out! Congrats!

Yeah sure…Thanks more @raff

Unfortunately, in order for someone to edit that page, the person needs to have full admin access to wordpress, which is quite a big thing. We cannot grant full admin access to every release manager, hence we ask in the process to create us a ticket to update the pages.

Due to my timezone, and the fact I’m only one, I do ask people to raise tickets when they need access, so others have a chance to help you with your request. I was going to bed, so I assumed you’d receive faster feedback if you raised the tickets.