Restarting OpenMRS

Hi, everyone! I need help restarting OpenMRS. At setup I run the OpenMRS server for the first time but it did not run successfully citing a failure /WEB-INF/view/uncaughtException.jsp (line:[9],column:[0] Unable to find tag lib[c] for URI: [WEB-INF/view/module/legacyui/taglibs/c-rt.tld]. I went a held and cloned the legacyui module and following the User Interface Modules - Documentation - OpenMRS Wiki I made a successful build. I copied the legacyui-1.10.0-SNAPSHOT.omod file to the modules folder. I have tried to read on how to move forward after that but I can’t find a clear way on how to restart OpenMRS tomcat since I run the server using the sdk. When I do mvn openmrs-sdk:run it shows that port 8080 is in use. I have tried to resolve this since yesterday morning reading thru the wiki but I have so far not been successful. Would someone please point me in the right direction?

I have tried to restart the serve and got this internal server error. legacyui error - @ruhanga and anyone who can help.

Did you try stopping the SDK by pressing? CTRL + C

I have done that now

Hi @dkayiwa @ruhanga mvn openmrs-sdk:run stopped - logs for cmd Internal server error - I have restarted the process a number of times and those errors are the latest I have encountered! Please help again

Which version of the SDK are you using? @irenyak1 am sure you can help here. :grinning_face_with_smiling_eyes:

@ibukenya what version of the SDK are you using? Try starting your server with this command

mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:4.1.1:run 

Just putting this post here for your reference.

1 Like

@dkayiwa, @irenyak1, The sdk show version 4.2.0

What is the command you are using to start your server?

mvn openmrs-sdk:run

Try starting the server with the above command I shared.

Is there a problem with sdk version 4.2.0?

Have you tried starting the server with the command I shared. And What is the result?

Error recieved:

@irenyak1 I have run the command and the error above came up.

@ibukenya could you use and send the entire log.

I had deleted the server. now I am running the command you sent.

@irenyak1 I have run the server. now at login and I am being asked for a location! Which one is appropriate btn inpatient ward, isolation ward, labaratory, outpatient clinic, pharmacy, registration desk?

choose any of the locations it does not matter

@ irenyak1 What happens here?