REST api (patient creation) ConversionException: identifiers on class org.openmrs.Patient

Can you point me in that, where to look for a patient identifier type with uuid “d793bee-c2cc-11de-8d13-0010c6dffd0f”?

Thanks for this, it was most probably copy paste drop did not work

with 8d793bee-c2cc-11de-8d13-0010c6dffd0f either

  "uuid": "8d79403a-c2cc-11de-8d13-0010c6dffd0f",
  "display": "Old Identification Number",
  "links": [
      "rel": "self",
      "uri": ""

curl -X POST --header ‘Content-Type: application/json’ --header ‘Accept: application/json’ -d '{ “identifiers”: [{ “identifier”:“abc123ez”, “identifierType”:“8d793bee-c2cc-11de-8d13-0010c6dffd0f”, “location”:“b1a8b05e-3542-4037-bbd3-998ee9c40574”, “preferred”: true }],

“person”: { “gender”: “M”, “age”: 47, “birthdate”: “1970-01-01T00:00:00.000+0100”, “birthdateEstimated”: false, “dead”: false, “deathDate”: null, “causeOfDeath”: null, “names”: [{“givenName”: “Thomas”, “familyName”: “Smith”}] }

}’ ‘

Can you use for the exact post body that you are using for uat02?


http: slash slash slash pvMWJYq9

On uat02 use this identifier type uuid (it has no validator): 8d79403a-c2cc-11de-8d13-0010c6dffd0f slash 3KWeaCPT no luck (

First log in and then immediately try to post again.

slightly better but still KO anyway slash UYkB4zAd

what is wrong then is the id format correct ? ?

Try it again now.

Very good it worked, thanks

but it does not work from soapui, should i try session authentication instead of basic ?

and how am i supposed to get the code abd database that works on uat02 on my dev box?

Just change the uuids in the post to those in your local database and then try again using the same url after replacing “” with “localhost”.

well, why it does not work now on uat02 from soap ui ? i copu paste the working sample from web client

and please, how am i supposed to find uuid of the id that has no validation on my local db? thanks again

For SoapUI, you are not sending authentication information. So you need to find out how SoapUI deals with sending user name and password.

On your local db, you can go to this page and then turn off patient identifier validation.

@dkayiwa I am having a similar issue. That is what I was trying to explain in this post

Can you please help me with that? It’s urgent :slight_smile:

@ivange94 i usually do not immediately jump onto such because am used to seeing you figuring it out a few hours later. :smile:

Hello Folks Actually I am facing an issue while creating patient from client etc postman with non admin account. I am using LBAC in my Instance So I have created A location and user for that location.

Through which I tried to create patient And Its creating the patient successfully but the same patient is not accessible or searchable for that non admin account but accessible with admin.Please do help me on this.


Try to rebuild the search index: Login

Thanks @dkayiwa for the response I have re build the search index but facing same issue.