Requested resource not available.

I tried creating my own module following the steps shown here:

I ran the command: mvn openmrs-sdk:create-project and have successfully created my own trial module. I fixed all the initial errors and started to see the demo code. I uncommented some of the code because I wanted to test it out. I built and uploaded it successfully in my OpenMRS. However, when I click the link to access the trial module I created, this shows up. (See image below)

Did I miss a step somewhere? Thanks for the help.

Do you have a jsp names trialmodule.jsp in the webapps folder of your module? Alternatively you can use the OpenMRS SDK to create the module.

I have the same problem. When i create example module with OpenMRS SDK command mvn openmrs-sdk:create-project and then mvn clean install openmrs-sdk:run and go to http://localhost:8080/openmrs/admin/index.htm and then found my module and click on it i get HTTP Status 404 -

type Status report


description The requested resource is not available.

Apache Tomcat/7.0.67

Can you help me?

@maryjis May I know what version of OpenMRS you are using?

I use 2.0.5 openmrs version

Is it just a problem of accessing the admin page? Or is it a problem of accessing your module through the admin page? Can you post a screenshot?

Maven clean and install works fine but when i am trying to access index.htm page it show 404 not found(HTTP Status 404 - /openmrs/index.htm)

When you run openmrs, what do you have on the console or logs?