Reports list is empty

Hi @all,

I’m having a problem with reports, the list is empty. The content of the file /var/www/bahmni_config/openmrs/apps/reports/reports.json is like in the link.

Bahmni v0.92

@gsluthra @angshuonline do you have any idea where the problem could be?

Maybe you can validate and check if the reports.json file has some error? You can paste it here and see:

Also, check if the contents of the json (attribute values) are not invalid/unsupported.

You can also use the Chome Dev Tools (or Firefox dev tools) to see if there is any error in the “Console” or in the “Network” tab – from the perspective of loading the report json files.

1 Like

Thank you @gsluthra for the recommendation it worked, it looks like the reports.json file was not the right one.

Now I’m having this problem, any suggestions about this error?

after restarting the service for bahmni-reports with “sudo service bahmni-reports restart” command this was the output.

It appears that your connection to OpenMRS DB (MySQL) is not happening. Please check if DB is running:

Hi @gsluthra, thank you for replying.

I have checked the connection it looks ok MySQL is active. Also, I have checked the /etc/bahmni-reports/ file, and is like in the next image. Should be like this?

p.s just to mention for testing purposes I have saved the content of the file in

Hi @gsluthra, The problem looks like is the service is not running.

I have tried those:

  1. sudo service bahmni-reports restart
  2. sudo systemctl status bahmni-reports.service