Reporting REST "Unknown resource" error


I am trying to access reports data via REST, but no url as explained in wiki ( works for rest calls to reporting data.

The exception thrown is here The url used for rest call is . The module has data definitions as shown in images attached

The versions are below :

  • OpenMRS: 1.9.7
  • Rest Web Services : 2.9.39bd19
  • Reporting Compatibility : 1.5.8
  • Reporting : 0.9.3
  • Reporting rest module: 1.4

The module shows successful installation in manage modules. Am I using correct url and software versions for this?

@darius @ahabib

Try (note the case difference). I noticed in a comment on the module Wiki page that the module documentation is outdated.

Thanks alot @ahabib . This resolved the issue.

I am facing the similar issue for the url: http://localhost:8080/openmrs/ws/rest/v1/user?v=full&username=test

Unknown resource: v1/user

Do you have the webservices-rest module installed and running?

Yes I installed Rest Web Services of V 2.8.19024c, when I run Testing REST URIs I am facing the same error as I mentioned earlier

msg: error
errorThrown: Internal Server Error
req: [object Object]
readyState	4
success	[POINTS BACK TO done] 
error	[POINTS BACK TO fail] 
responseText	"{\"error\":{\"message\":\"Unknown resou..."
status	500
statusText	"Internal Server Error"

What is the version of OpenMRS and module you are running?