Reporting module is not running with 2.11 reference application

Tags: #<Tag:0x00007f828d548140> #<Tag:0x00007f828d548050>

@dkayiwa @sharif @ibacher I try to completely test 2.11 in my local machine. Reports are not working when I try to generate via the admin screen. Please refer to the attached screenshot and pin logs. It worked well on the 2.10 version.

1 Like

How are you running Ref-app 2.11.0, is it the same scenario happened recently running ref-app 2.11.0 on docker container?

I guess you should first make sure reporting module is working fine, then you shift to building reports , could you share the logs using pastebin.com, hope you are following this running reports because it may be of help

Are you able to reproduce it here? https://qa-refapp.openmrs.org/

I tried it, but unable to reproduce it there. The difference between my local insurance and demo app is, test data there in demo app and I have no test data in my local machine. I just added few patients and vitals then try to produce reports.

Thanks

Prapa

Create demo data using this setting: referencedemodata.createDemoPatientsOnNextStartup

As per my understanding usecase, fresh instance need to be tested and added few patients for testing.

In that case, can you share your full server side log?

@dkayiwa Please verify line number 4435. I am guessing new changes breaking old reports. Fullllog.txt (1.1 MB)

SqlDataSetDefinition[List of New Patient Registrations]: Unable to retrieve columns for query

MySQLSyntaxErrorException: Expression #1 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'openmrs.pi.identifier' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by

What is the sql definition for the List of New Patient Registrations dataset?

@dkayiwa negative, unable to find query from log. I am running default report from admin. Are you able to pull it from code?. Is there way enable debug mode? I tried and unable to find it. @mozzy @mseaton

@dkayiwa This is just a default report from 2.11 reference application and shared all the details. Any help with this much appreciated.

Thanks Prapa

Can you turn off the only_full_group_by SQL mode using the command below and see if it helps?

SET GLOBAL sql_mode=(SELECT REPLACE(@@sql_mode,'ONLY_FULL_GROUP_BY',''))

If it works, then you may need to set it permanently in the MySQL config file. Otherwise, it will restore the old value on restart.

Sure, let me try and keep you posted soon.

Thanks

Prapa

@dkayiwa Yep, It is working as expected. Once the fix added with build, can you please let me know for checking full build.

I do not seem to understand your question.

@dkayiwa I meant it is working after adding set command to mysql-5.7. Is it possible to add set command in code while installing application.

Thanks Prapa

How did you set the command?

@dkayiwa Just connected with mysql command line and executed the set command like any other sql scripts.

Does it still work even after a restart of MySQL?