Removing omod 1_8 but facing challeges in compiling and excuting tests

hello everyone am currently working on this;

i have managed to transfer classes from omod 1_8 to 1_9 and also merge similar classes in both omods, succefully deleted the omod 1_8 and also it’s dependencies in the omod 1_9 pom.xml file but i have encounter an compile error also ending tests prematurely

i tried to mvn clean install and still ecounter the same error

i have created a pr Restws 741: removing omod 1_8 and transefering code to omod1_9 by josephbate · Pull Request #580 · openmrs/ · GitHub

please advise me on the way to go about this or any possible solutions

cc @wyclif @dkayiwa @ibacher @ruhanga @mozzy

Hey @josephbate ,this has more to do with the fact that you deleted the omod 1.8 but it is still being shown in the root pom.xml file e.g here → at 41fb2a3519bfb291034f0ba98cc1988ff12525fb · josephbate/ · GitHub.

Please search through the root pom.xml file and remove the submodule omod 1.8 and endeavour to ensure your branch is updated with changes from the master branch

1 Like

thank you for the reply let me try it out

1 Like