Remove submodule 1.8 Webservices REST ModuleRESTWS-741

Hallo guys I am working on this ticket Log in - OpenMRS Issues. I was able to remove the submodule and created similar classes in the submodule 1.9 also shifted some code to some classes in the 1.9 module because it was necessary for the 1.9 module tor work.

I have tried to run mvn clean package and this error log comes up Error log for RESTWS-741 - and it seems to be looping.

I need some help what could be the possible cause of these errors. @kdaud @jwnasambu

@suubi7 The error is Caused by: org.springframework.beans.factory.BeanDefinitionStoreException: Unexpected exception parsing XML document from class path resource [applicationContext-service.xml]; nested exception is java.lang.IllegalStateException: Annotation-specified bean name 'locationSearchHandler' for bean class
Kindly ensure you are not missing the starting tag of Beans .

1 Like

@jwnasambu could it be the same reason why this errors came up Remove 1.8 submodule-RESTWS-741. I deleted the 1.8 submodule and crea… by suubi-joshua · Pull Request #571 · openmrs/ · GitHub

Nop! they are different. In this case the error is Error: Child module /home/runner/work/ of /home/runner/work/ does not exist @ @

Kindly before incorporating the changes in the cloned project did you run mvn clean install to confirm the build runs successfully?

No actually I didnt do this. I had only run mvn clean package.

Its fine the is a first time of everything. Here are some few tips before making any changes on a file:

  • Ensure the branch is up to date origin/master git status

  • Then connect your local repository to the remote serve using git remote -v command

  • The project builds successfully before making any changes mvn clean install

  • Create you branch them make your changes now

Note: Always run mvn clean install command on a master branch and just incase you have an error first ping a senior dev to provide you with the way forward.

Ahhhh okay let me do that now and see. @jwnasambu thank you

@jwnasambu I have made several adjustments again. Though the errors now are different but understandable but their are some that are not making sense. Error log is here New Error log on RESTWS-741 - Most especially on this error BaseContextSensitiveTest.executeDataSet:546 » FileNotFound

What does this error mean. When I open the class BaseContextSensitiveTest it requests me to set the path though not sure which path I should set for it. @mozzy @sharif @jnsereko @dkayiwa

This happens when I run mvn clean package.

Kindly run mvn clean install instead of mvn clean packages.

@jwnasambu Still the same error log showing up.

The command wasn’t meant to fix the error but what I am trying to communicate is that this 2 commands are different. Besides, is the error you are getting is as a result of making changes or not?

Ohhh Okay Yes the errors are after making the changes