Reference Application

Hi,

I am new to OpenMRS and I want to install it at my machine. I tried to clone openmrs-distro-platform and run the resulted WAR to tomcat. However it was run without front end.
My qestion is about what are the steps shlould i follwo to run the full OpenMRS 3 like the one on OpenMRS demo.

Did you try these instructions? https://github.com/openmrs/openmrs-distro-referenceapplication/blob/main/README.md

You could also use the SDK to setup O3 reference application: O3 Implementer Documentation: Set Up, Configure & Deploy - Projects - OpenMRS Wiki

Actually I have followed the instruction of " Setup the O3 distribution with the SDK." and everything was ok. but when i tried to open the http://localhost:8080/openmrs/spa/ it gave me a blank page.

my selected options were as the following: 3) O3 Distribution

  1. Reference Application 3.0.0-SNAPSHOT MySQL 5.8
1 Like

Sometimes if the computer is being slow, you may first see a blank page as it laods… otherwise you might need to check the logs(or share here with pastebin) for other possible causes…

Yes sure here is it WARN - OpenmrsUtil.getRuntimePropertiesFilePathName(2033) |2023-10-04T15:24:35,1 - Pastebin.com. from the log i noted that the frontend\index.html’ doesn’t exist

1 Like

It looks like you are facing the same issue that was discussed here: Slack

It was fixed yesterday. So just run the OpenMRS SDK setup again to create a new server.

1 Like

It seems there is another problem yet. during the set I got this issue Downloading from openmrs-repo-thirdparty: https://mavenrepo.openmrs.org/thirdparty/org/bahmni/module/appointments-omod/2.0.0-SNAPSHOT/appointments-omod-2.0.0-SNAPSHOT.pom

Can you share the logs with pastebin.com?

@dkayiwa I am getting the same error: /usr/lib/jvm/java-8-openjdk-amd64/bin/java -Dmaven.multiModuleProjectDirectory=/ - Pastebin.com. I think there is a problem with jfrog.

1 Like

Here is it [INFO] Configured Artifact: org.openmrs.distro:referenceapplication-distro:3.0.0 - Pastebin.com

Till that gets fixed you could try using the Reference Application 3.0.0-beta.13.

I have just added the bahmni snapshot repository Adding bahmni snapshot repository · openmrs/openmrs-sdk@1e632e5 · GitHub

1 Like

I’ve add that snapshot repo to the JFrog instances Public, so 2.0.0-SNAPSHOT should now be available with no tweaks (the Mekom repo is a special snowflake for reasons I don’t understand).

1 Like

Still not available yet:

{ “errors”: [ { “status”: 404, “message”: “Item thirdparty:org/bahmni/module/appointments-omod/2.0.0-SNAPSHOT does not exist” } ] }

I don’t think the release with the changes is still out. Checkout after some time.

1 Like

Could you try it again? I’m able to resolve it with Maven like this:

mvn dependency:get -Dartifact=org.bahmni.module:appointments-omod:2.0.0-SNAPSHOT:jar -DremoteRepositories=openmrs::default::https://mavenrepo.openmrs.org/public/

unfortunately. i got the same issue even applying Slack. here is the log WARN - OpenmrsUtil.getRuntimePropertiesFilePathName(2033) |2023-10-07T11:50:37,8 - Pastebin.com

does the openmrs initial setup start? Does it show you an error?? Is the setup stuck on a specific value?

Yes it started and end successfully. However there was a samll issue regarding " Patient Flags Module " not started because of Caused by: java.sql.SQLException: Referencing column ‘role’ and referenced column ‘role’ in foreign key constraint ‘patientflags_tag_role_ibfk_2’ are incompatible. and this should not be a show stopper of SPA module.