Reference Application SNAPSHOT-2.7.0 Not Yet on UAT-Server

The Community should be already testing RefApp 2.7 however according to a careful audit most of the module versions at the uat-server are not up to date with the latest versions of the Distro pom.xml ,Can we have them updated ,or rather have RefApp SNAPSHOT - 2.7.0 deployed on the uat server and 2.6.0 undeployed @cintiadr ?

FYI @dkayiwa , @darius , @burke

Hi,

Look, in order to deploy a version to UAT, it requires to create a new Bamboo deployment and deploy it: https://ci.openmrs.org/deploy/viewDeploymentProjectEnvironments.action?id=93650946

So, for example, assuming you want to deploy commit 38ec094c65aded69d02c550b568a1b5c7a79b6ba/Build #6971, you need to click on:

21 PM

Give it a name like ‘Pre-release’, or RC1, or anything. And then you’d be presented with the option to deploy to UAT. After the deployment, it can take a couple of minutes to propagate.

If that still doesn’t work, I can look the logs to see what happened.

(Right now the Bamboo queue is a little bit big because the agents were offline for a few hours, so please be patient).

You can even confirm that the tag ‘UAT’ was last updated 5 months ago:

https://hub.docker.com/r/openmrs/openmrs-reference-application-distro/tags/

So nothing was attempted to be deployed to UAT.

@cintiadr thanks alot .Let me work on that

@cintiadr Which build plan can i use to create the deployment project ? The one i have tried so far has no artifacts associated with them.

@tendomart, it’s easier if you follow bamboo interface:

But it appears that @dkayiwa already deployed build 6981 to UAT. @dkayiwa, don’t you want to rename the bamboo release from ‘Reference-Application-2.7.0’ to ’ Reference-Application-2.7.0-rc1’ or something, as deployment releases are unique in Bamboo and the release 2.7.0 wasn’t actually done yet?

@cintiadr alright thanks alot.Confirmed . @dkayiwa has deployed.