Reference application misconfiguration

Hi folks,

I am still battling with getting openmrs to work properly. I resolved to go down from platform to version 2.0.6 which seems to work better for me.

After the upgrade from 1.9.9 to 2.0.6, I did not copy any of the module from reference application 2.7.0 folder because the installation itself gave me the new UI and other features. I explore the /usr/share/tomcat7/.OpenMRS/modules/ folder and it was empty, so I left it that way since I am fine with the setup.

now here are my challenges:

  1. Occasionally I get the error

UI Framework Error Root Error org.openmrs.ui.framework.UiFrameworkException: viewProvider referenceapplication does not have a view named login

My temporal solution is to stop and restart openmrs from tomcat

  1. Every time I boot the server machine it loads the legacy UI, and the following modules will stop: Reference Application Module Reference Metadata Module Reference Demo Data Module

I will have to restart them manually and reload the page. I try setting their mandatory and started properties to true in the global_properties table but they all reset to false on every launch.

  1. When I try finding a patient via the new UI it throws the following error

UI Framework Error Root Error org.openmrs.module.emrapi.descriptor.MissingConceptException: Couldn’t find primary concept for DiagnosisMetadata which should be mapped as org.openmrs.module.emrapi:Diagnosis Concept Set

Here are some fixes I tried but they did not work: a. I created a concept I called ‘Diagnosis category’ class=ConvSet Is Set=true Set Members=[I added some diagnosis] Datatype=N/A

b. I added a new global property called ‘emr.concept.diagnosisSetOfSets’ and set its value to the uuid of the ‘Diagnosis category’ concept

c. I went to Manage Mapping and added a new mapping as follows: Metadata Class=emr.concept.diagnosisSetOfSets Metadata Source=org.openmrs.module.emrapi Code=emr.concept.diagnosisSetOfSets

d. Restarted tomcat and reload page

My Observation: I notice that the reference modules do not start if i try starting them from the legacy UI.

Please I need answers most especially number 3 error.

attached is my log file.

https://drive.google.com/file/d/1V41TZzLXD0OwNqHMFpwlqYoYbBPBDCKq/view?usp=sharing

Do you have any reason for using reference application 2.7.0 instead of the latest release of 2.8.0?

I use platform 2.1.3 and ref app 2.8.0 initially and many modules did not start including the 3 ref modules I mentioned earlier so I had to start them manually, that was one reason. When I install openmrs 2.0.6 I did not have to copy the modules to the module directory, and I was comfortable with that.

secondly, the release of 2.1.3 and 2.8.0 are very new, so I felt going further with these version I may run into issues that I may not have more of the forum members support/experience with.

Do you still have the tomcat logs for the case where you tried out the reference application version 2.8.0? I would be very interested in looking into why those modules do not start with our latest release.

No, but I will re-do it with reference application version 2.8.0 and send that to you in some couple of hours. Just to ask:

where exactly will I find the tomcat log in ubuntu 16.04LTS?

Did you try googling that? :blush:

I will do all you suggested and get back to you, thanks.

Hi Daniel,

Thanks for your time. I have setup platform 2.1.3 and reference application 2.8.0 it is still the same issues.

See included links catalina.log - https://pastebin.com/1TH23zxX other supporting files - https://drive.google.com/file/d/1_y7bdyTDul29e25DB9MKOi5B8FPNl8gn/view?usp=sharing

Now another new malfunction observed with reference application 2.8.0 is that When I click on any item on the dashboard (like Capture Vitals, Register patient, etc) and click the home button to go back, it return me to the index.htm page which says

‘If you are seeing this page, it means that the OpenMRS Platform is running successfully, but no user interface module is installed. Learn about the available User Interface Modules…’

with version 2.0.6 I did not get this behaviour.

Also the CSS does not take proper effect on the links in System Administration, they all appear as normal html links.

Just to understand the circumstances, what you upgraded was not the reference application. Correct?

Formally it was 1.9.9 in use, I then ran an upgrade over an existing database (satisfying all upgrade criteria) using platform 2.1.3 and download the Reference Application 2.8.0 Addons.

So to get the context right, the upgrade from 1.9.9 to platform 2.1.3 happened successfully? The problem was when you dropped in the reference application 2.8.0 addons/modules?

Very correct Daniel, that is it. The upgrade from 1.9.9 to platform 2.1.3 happened successfully.

Was your 1.9.9 implementation using the CIEL dictionary?

https://wiki.openmrs.org/display/docs/Getting+and+Using+the+MVP-CIEL+Concept+Dictionary

Am asking the above in reference to this: Non CIEL implementation for Reference Application

Thanks for the insight from the links you shared. However, I am not using the CIEL dictionary. From the point I am now what is the way forward?

After successfully upgrading to platform 2.1.3, stop tomcat and delete all logs. Then drop in the reference application 2.8.0 modules. Start tomcat and share the new logs.