Reference Application 2.4 Released

Hello all,

We are happy to announce OpenMRS Reference Application 2.4 has been released :smile:

Reference Application 2.4 includes: the latest platform release i.e. 1.11.6 (done by Musoke Steven) several bug fixes and new versions of lots of modules released by several developers listed below.

I would like to specifically thank @ssmusoke, @wyclif , @maurya, @ryan , @burke , @darius , @raff , @dkayiwa , @jthomas , @k_joseph and the Infrastructure Team for making things whole lot simpler and quick. All of these people have been amazing in terms of quick responses, patience and understanding.

Feature highlights from Reference Application 2.4 37 modules OpenMRS Platform 1.11.6 (Maintenance release by Musoke Steven)

Complete list of code contributors to Reference Application 2.4 (apologies if anyone’s name has been missed):

Stephen Senkomago Musoke, Abhishek91, A Chethan, Alexei Grigoriev, Bharat K, Burke Mamlin, Cintia Del Rio, Clifton McIntosh, Cosmin Ioan, Darius Jazayeri, Daniel Kayiwa, Deluan Quintão, Gaurav Narula, Goeffrey W Wasilwa, Hemanth Gowda, Hanswurst, Imran Tatriev, Indraneelr, Izaron/Evgeny, , James degraft-Johnson, Judy Gichoya, Jakub Kondrat, Kaweesi Joseph, Kristopher Schmidt, LavaSnake, Lluis Josep Martinez Ferrando, Mario Somrei, Mark Goodrich, Michael Hofer, Michael Seaton, Miguel Corrales Mhawila, Mekom Solutions, Namrata Nehete, Nicholas Ingosi Magaja, Nicholas Folk, Ojwanganto, Padma, Patrick Lehmann, Paweł Muchowski, Preethi Sadagopan, Rafal Korytkowski, R Sudhakar, Ranganathan Balashanmugam, Romain Buisson, SwathiVarkala, Shruthidipali, Stefan Neuhaus, Sravanthi 17, Sam Dale, Sebastian Theis, Saptarshi Purkayastha, Tim Steen, Tomaszmueller, Ujjwal Arora, Vinkesh, Vinayvenu, Vikash Gupta2000, Willa Ahmed, Wesley Brown, Wyclif Luyima, Yousef Hamza, Xiang Li, YS-Achinta, Robby O’Connor

We have done UAT testing for RA-2.4 quite some weeks as posted. A big thank you to all who took time to go about and test :smile:

Official announcement:innocent: Release Notes

Regards,

James deGraft-Johnson

On behalf of OpenMRS

11 Likes

@jdegraft, congratulations and many thanks for helping release Reference Application 2.4!!! :smile:

FYI - I’ve edited your post here to reflect our current branding – i.e., “Reference Application 2.4” instead of “OpenMRS 2.4” to help distinguish Reference Application vs. Platform releases.

I noticed that the artifacts in SourceForge include “openmrs-standalone-1.11.6.zip”. Isn’t that supposed to be “openmrs-standalone-2.4.zip”?

Also, the Download button on the download page is pointing to the standalone package (modules to be added). I’m assuming that should point to “openmrs-standalone-2.4.zip”).

Great work everyone!

Mark

If I download openmrs-standalone-1.11.6.zip (what I believe should be renamed openmrs-standalone-2.4.zip) into a fresh ubuntu 16.04 instance, I see some strange MACOSX entries in the zip archive:

$ unzip -lf openmrs-standalone-1.11.6.zip

Archive:  openmrs-standalone-1.11.6.zip
  Length      Date    Time    Name
---------  ---------- -----   ----
        0  2016-07-13 14:12   openmrs-standalone-1.11.6/
        0  2016-07-13 14:00   openmrs-standalone-1.11.6/appdata/
        0  2016-07-13 14:00   openmrs-standalone-1.11.6/appdata/modules/
   238859  2016-07-13 14:00   openmrs-standalone-1.11.6/appdata/modules/adminui-1.1.omod
        0  2016-07-14 00:10   __MACOSX/
        0  2016-07-14 00:10   __MACOSX/openmrs-standalone-1.11.6/
        0  2016-07-14 00:10   __MACOSX/openmrs-standalone-1.11.6/appdata/
        0  2016-07-14 00:10   __MACOSX/openmrs-standalone-1.11.6/appdata/modules/
      212  2016-07-13 14:00   __MACOSX/openmrs-standalone-1.11.6/appdata/modules/._adminui-1.1.omod
    72019  2016-07-13 14:00   openmrs-standalone-1.11.6/appdata/modules/allergyapi-1.4.omod
      212  2016-07-13 14:00   __MACOSX/openmrs-standalone-1.11.6/appdata/modules/._allergyapi-1.4.omod
    71596  2016-07-13 14:00   openmrs-standalone-1.11.6/appdata/modules/allergyui-1.5.omod
      212  2016-07-13 14:00   __MACOSX/openmrs-standalone-1.11.6/appdata/modules/._allergyui-1.5.omod
  1653984  2016-07-13 14:00   openmrs-standalone-1.11.6/appdata/modules/appframework-2.8.omod
      212  2016-07-13 14:00   __MACOSX/openmrs-standalone-1.11.6/appdata/modules/._appframework-2.8.omod
  1529055  2016-07-13 14:00   openmrs-standalone-1.11.6/appdata/modules/appointmentscheduling-1.5.omod
      212  2016-07-13 14:00   __MACOSX/openmrs-standalone-1.11.6/appdata/modules/._appointmentscheduling-1.5.omod
  2258990  2016-07-13 14:00   openmrs-standalone-1.11.6/appdata/modules/appointmentschedulingui-1.3.omod
      212  2016-07-13 14:00   __MACOSX/openmrs-standalone-1.11.6/appdata/modules/._appointmentschedulingui-1.3.omod
    27579  2016-07-13 14:00   openmrs-standalone-1.11.6/appdata/modules/appui-1.5.1.omod
...

Any chance @jdegraft or @dkayiwa is using a Mac and accidentally introduced these __MACOSX artifacts into the archive?

/cc @maurya

@burke, I used a mac.

I am able to upload the files again from a PC, should I go ahead?

Hello @jdegraft,

Great Work! :slight_smile:

me and @burke are taking care of it right now. Don’t upload any new files to the folder.

@maurya, sorry you need to redo what you are doing, I tried to do the upload again. I will now leave it up to you. Thanks for your help.

@jdegraft, no worries. I worked with @maurya and I think we’ve got it sorted: renamed to “openmrs-standalone-2.4.zip” and “openmrs-2.4-modules.zip” to follow conventions of prior releases and updated download.openmrs.org accordingly. I think we’re good.

Thanks again for seeing this through, @jdegraft. You rock!!! :thumbsup: :guitar: :musical_note:

2 Likes

Great work @jdegraft!

1 Like

Good work @jdegraft, may be we also need to update the folders in the reference application release for 2.4 at source-forge, it creates a standalone 1.11.6 folder instead which may bring confusions

@k_joseph, source-forge has the correct folders, can you confirm this? Thanks.

Hey, there’s a problem on the http://openmrs.org/download/ page – the section about Reference Application 2.4 has a link to download Platform 2.0.0 WAR + Reference Application 2.4 Modules & Data. This is wrong, because Refapp 2.4 is supposed to be built on Platform 1.11.x (and AFAIK that module bundle will not run at all on Platform 2.0.x). So the link should be to download Platform 1.11.6.

@jdegraft, @maurya, or @jeffneiman, is this something one of you can fix?

@maurya, can you help with this? During Ref app 2.4 release, I think the procedure was to submit a help ticket for these links to created, but I am not sure. I don’t remember having access to update this page.

@darius - Thanks for noticing this , updated the page accordingly.

1 Like