Reference Application 2.11 Module Release Tracking: Deadline october 2020

Tags: #<Tag:0x00007f828d00b6f0>

Hi @sharif can you link to the actual Bamboo logs ,not just what you pasted ??

It may provide more details

1 Like

Check out here https://ci.openmrs.org/browse/REFAPP-OMODDISTRO-10326

Thanks @mogoodrich for tramendous work in releasing ready modules and updating the wiki page

Am releasing these 6 modules .

REGISTRATIONAPP 2.20.0

REGISTRATION CORE 1.10.0

REPORTING 1.21.0

REPORTING COMPATIBILITY 2.0.7

REPORTING REST 1.11.0

REPORTING UI 1.7.0 cc @mseaton @mogoodrich i would also remind other module maintainers that the releasing of modules deadline is this coming week on thursday thanks

@sharif - neither reportingrest nor reportingui have had any commits made that require releasing since their last releases. We should use reportingrest 1.11.0 and reportingui 1.7.0. I have updated the wiki page.

Regarding the reporting module, I tried releasing via Bamboo, and it failed due to the fact that the 2.4 profile is building against the 2.4 snapshot. I was hoping to update this to reflect an alpha or beta release of 2.4 but did not see one in Maven. We’ll need this in order to proceed with the module release.

Best, Mike

1 Like

thanks @sharif!

I had hoped to get to releasing Registration Core and Registration App this week, but if you get to it first, feel free.

I also looked the REST web services module and I think it has the same problem that @mseaton is seeing for the Reporting module… we will need an alpha or beta version of Core 2.4.x released first.

As for the remaining ones on my plate:

  • HTML Form Entry has a dependency on Core 2.3.2-SNAPSHOT, so I can release that after the 2.3.2 version of Core is released. (I know this is currently being worked on)

  • I will do the UI Commons release in the coming days, I started working on it on Friday

  • I should be able to do the Provider Management release this week as well

  • Core Apps has a potential bug that needed to get fixed before release. We are looking into that now.

  • Looks like someone just released the OWA module, so I’m thinking that is all set?

Thanks @mseaton for checking inn, Will try cross checking with those modules

can it run on 2.3.1, or you wanted it basically on 2.4

Thanks if your plan is to make it depend on 2.4 , it would inquire us to work together because our deadline seem to be this week, thanks

Thanks @mogoodrich , i get your point , i hope platform of alpha will be soon getting released probably by the ed of this week cc @gcliff any feedback on your alpha release

Sure @jwnasambu is working on this, Any progress please on this

Thats very great @mogoodrich

i will release this module , no worries expect if you have significant work to bundle

i guess its related with RA-1800, we surely need it , Am ready to help in this

Thanks @mogoodrich lot for driving this i appreciate, best regards to @mseaton too

Am finalizing with the rudimentary testing.

1 Like

yes @sharif @mogoodrich i have openmrs core 2.4.x alpha released to maven here https://ci.openmrs.org/browse/TRUNK-CORE-4, you can switch to 2.4.x-alpha and release the blocked modules

1 Like

Thanks @gcliff! I will get to doing the module release in the next few days!

1 Like

@mogoodrich @mseaton i have been trying to release the rest module but my attempts have been failing, just want to inquire is its the similar kind of error that you have been facing

Thanks to those who released modules recently

I have successfully released these below modules

  • Registration core to 1.10.0
  • Registration app to 2.20.0
  • ProviderManagement to 2.12.0
  • Idgeneration to 4.6.0
  • DataExchange to 1.3.5

So we are now remaining with

  1. reference metadata 2.11.0-SNAPSHOT

  2. reference application 2.11.0-SNAPSHOT 3.uilibrary2.0.6-SNAPSHOT

  3. Reporting 1.21.0-SNAPSHOT

  4. htmlformentry3.12.0-SNAPSHOT

  5. coreapps.30.0-SNAPSHOT

  6. webservices.rest2.29.0-SNAPSHOT

  7. formentryapp1.4.3-SNAPSHOT

9.atlas2.3-SNAPSHOT

10.reportingcompatibility2.0.7-SNAPSHOT

  1. attachments 2.3.0-SNAPSHOT.

  2. referencedemodata1.4.6-SNAPSHOT

remaining modules not listed above am working on the now but some of them are ready to be shipped

In regards to the failures to release the rest module via bamboo ci ,i see in the logs

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-release-plugin:2.5.1:prepare (default-cli) on project webservices.rest: Can't release project due to non released dependencies

in the rest POM i see the maven release plugin version pointing to 2.5, we can upgrade it to 2.5.1 so that it matches to org.apache.maven.plugins:maven-release-plugin:2.5.1

cc @dkayiwa @mogoodrich @mozzy @ruhanga Any thoughts on this ?

1 Like

I’m carrying out a rudimentary testing for platform 2.3.2 minor release but am blocked and I need help to proceeded. These are the steps I followed to setup a testing server.

  1. I cloned the openmrs core project, switched to 2.3.x branch from the master branch then ran mvn clean install to access the openmrs.war file. which I renamed openmrs-2.3.1.war

  2. I deleted the openmrs-2.3.1.war file in the sdk instance RefApp version 2.11.0 snapshot and replaced it with the openmrs-2.3.1.war file from openmrs core.

  3. I switched of the machine then started it a gain.

  4. when I run mvn openmrs-sdk:run on the command line, I get this screen

  5. When I click next, I end up with this screen

  6. After clicking next, this is the output

and these are the logs https://pastebin.com/x9X4nbv6. Kindly how can I go about this blocker?

cc @mogoodrich, @dkayiwa @ibacher

The issue is sorted out! I simply repeated the process of setting up a testing server from scratch.

That’s great @jwnasambu , so is that branch ready

@gcliff

build 22-Sep-2020 06:38:45 [ERROR] Failed to execute goal org.apache.maven.plugins:maven-release-plugin:2.5.1:prepare (default-cli) on project webservices.rest: Can't release project due to non released dependencies : build 22-Sep-2020 06:38:45 [ERROR] org.openmrs.api:openmrs-api:jar:2.4.0-SNAPSHOT:provided

The above is the cause of the error. Change that dependency from a snapshot version.

2 Likes

@dkayiwa @mogoodrich @sharif i have released the rest module https://ci.openmrs.org/browse/RESTWS-RESTWS-982

1 Like

@jwnasambu thanks for the work done.

i havent understood the steps you have explained …

can you just simply use the sdk to setup a platform 2.3.2-snapshot server ??

Oh sorry! which step is confusing? the blocker was sorted out and am testing.