Reference Application 2.10-SNAPSHOT testing sprint!

Tags: #<Tag:0x00007f569d354300> #<Tag:0x00007f569d354238>

As we prepare for the final release of Reference application 2.10 soon,we would like to call on the members of the community to help in the final testing of Reference Application 2.10-SNAPSHOT.This is to end on 4TH MARCH 2020.Kindly follow the test case here from the QA team https://docs.google.com/spreadsheets/d/1YyyK9_lPpFghSKR14NqI8JC4WIp-v0FMtSjBRCStXKc/edit#gid=671894271 .Tests can be done on this sever

uat-server

in case of any questions you can reach out to @herbert24 @christine cc @mozzy @jwnasambu @irenyak1 @reagan @sharif @tendomart @dev1 @dev2 @dev3 @dev4 @dev5 @jennifer

2 Likes

Thanks for reminder @herbert24

@herbert24 , i Undesrtand the Sprint has ran for some days , Any Updates/Blockers/results so far ?? cc @christine

hi @mozzes,i have managed to carry out a couple of tests as seen on the QA test script here https://docs.google.com/spreadsheets/d/1YyyK9_lPpFghSKR14NqI8JC4WIp-v0FMtSjBRCStXKc/edit#gid=671894271 A couple of things are good to go,so far i have seen only one thing which is the login button.Kindly check it out its colour has to be green.

1 Like

@rmkanda hello how have you been,could you kindly add your results for testing the reference app 2.10 snapshot on the reference application test case here https://docs.google.com/spreadsheets/d/1YyyK9_lPpFghSKR14NqI8JC4WIp-v0FMtSjBRCStXKc/edit#gid=671894271 . @ibacher hei ian did you manage to get some time to do the testing as you had said? cc @christine

1 Like

Hello , well done all for all the great work done. , any other issues found apart from the Login Button Colour ?? cc @rmkanda @christine ?? Otherwise we are good to go to the full release so far :slightly_smiling_face:

1 Like

as soon as we do not have any by tomorrow,we shall get the full release

1 Like

the sprint will be ending tomorrow

1 Like

@reagan or @gcliff , can some one fix for us the Login Button colour ?? Current colour as at qa-server

Ideal colour as at at demo-server

1 Like

Will fix it early tomorrow.

1 Like

@reagan no worries i am making the fix now

1 Like

Cool…Thanks.

1 Like

@mozzy Please refer the issues here

1 Like

thanks @rmkanda and well done

Hi @rmkanda thanks for good work, i have been testing to comfirm your testing, Seems your first approach is different, which servers are you using such that we can be on the same track because so fur mine is ok, Part 1 of your RA resting

Great work @rmkanda , @herbert24 and @christine , i will surely get time to look through the issues and ticket them down . weldone.
Thanks too @sharif
cc @reagan @ruhanga

1 Like

So fur i have tested four parts one for Patient marked as deceased which requires a fix for dropdown menu for deceased patients.

Another fix is in edit visit in patient dashboard page , which is to be first fixed in RA 2.9.0 this edit visit link seems to be not functioning . i went ahead and created a ticket for that https://issues.openmrs.org/browse/RA-1712 , @mozzy you can as well go ahead and comfirm it and make it ready for work if its still neccessary

Part 3 of the above link provided by @rmkanda ,is related to bootstrap , i think we should first ignore this for the first moment because when we try to reduce the size of the text areas and buttons, they are going to be very small. thanks all for great work cc.@mozzy @herbert24 @reagan @rmkanda

hei @mozzy will also be getting to you so that we compile all what is failing

Thanks @herbert24 and @rmkanda , i tried to reproduce the issues raised,

i summerised the comments below , NB the numbers below represent the issue in the google sheet with corresponding number

1 bug
2 Not a bug …see how to configure Mark Patient as Dead
3 Bootstrap related bug
4 Not a Bug , we removed chart search module from the ref app modules
5 Bug
6 Bug
7. Not a bug. requires improvement
8. Not a bug. Edit vist link displays when more than one Vist types exist.
9: Bug
10 . Not a Bug , intended
11. Bug. . Ui breaks
12. Bug . Ui breaks
13 . Bug
14. Bug
15 .Bug
16. Not a Bug .duplication is caused by a temporaly cache in the ui component,
cleared by refreshing browser

cc @sharif @reagan , we can go ahead to create the issues that i marked as bugs . i will make them ready for work

https://issues.openmrs.org/browse/RA-1713 (1) https://issues.openmrs.org/browse/RA-1714 (5) https://issues.openmrs.org/browse/RA-1715 (6)

cc @gcliff @jwnasambu @sharif @herbert24 you may be interested to log the rest.

2 Likes