Reference App 2.6: Can't search/find patients created by others

Application Name: Reference 2.6

Issue: Hi all! I’m implementing The Enterprise (non-Standalone) version of Reference application 2.6 on a server for a medical mission trip to Africa for next week. This is a simple/small setup to gather data during our clinics. I followed the instructions for installing 2.6 using the recommended WAR and 2.6 modules. Everything is working well except one area…

I’ve created 4 Provider accounts, and when one provider registers a patient, the other providers cannot find that patient using the main Search Patient button on the main UI homepage screen. Even the admin user cannot find patients created by others. I’ve fooled around with all of the roles/privileges and just can’t figure this one out.

I did notice that when one provider registers a patient, then sets the patient with an active visit…then other providers can see that active visit and go into the patient record. Then, if the provider creates a note on that visit…they can then find that patient using the main Search Patient button.

It’s almost as if there’s a “lock” in place preventing providers from finding a patient on the main search unless they have had some sort of recorded interaction.

I’ve uninstalled/reinstalled several times, wiping databases and config directories, tried upgrading modules (did more harm than good), etc…still having this issue.

Any thoughts/ideas? We’re leaving in about a week and if I don’t get this solved by then, I will go forward with one account for everyone to use…so they can all search patients as needed since one account is registering all patients. Not ideal…

Are you able to reproduce that here?

I was able to figure it out through examining default data in the SQL tables and installing on another system as a test. My initial system appears to have some sort of weird memory issue…I will be swapping out systems for now. Thanks!