Ref App breaking on release

The reff app release breaks on bamboo as per these logs , could any one have any suggestion of fix basing on the logs,thanks cc @dkayiwa @ibacher

I skimmed through the logs quickly and most probably issues are coming from modules you updated in distro-referenceapplication.

@herbert24 before releasing the ref app did you notice that for the modules you released and updated in the distro pom.xml, their Bamboo CI release build plan did not succeed on completion?

@dkayiwa @ibacher can go into a deeper review of the logs!

@herbert24 That build failed with this error message:

Detecting the current branch failed: fatal: ref HEAD is not a symbolic ref

Usually a symptom that we need to setup Git not to do a shallow clone of the repo. I’ve done that. However, the more recent failures are, as @kdaud pointed out, due to that commit. In particular, the release for adminui 1.6.0 doesn’t seem to have taken. No idea why since the logs for that release no longer seem to exist.

hi @ibacher @dkayiwa after fixing the versions and trying to release i run into, what i noted is this line from the logs( Unable to tag SCM),could you be having any work around on this

Hello @herbert24 Try changing this openmrs-distro-referenceapplication/pom.xml at master · openmrs/openmrs-distro-referenceapplication · GitHub from GitHub - openmrs/openmrs-distro-referenceapplication to

thanks @sharif it looks like we are using https not http

ohh i guess that’s where the problem is resulting from according to the logs

1 Like

The relevant bit from the log:

build	04-Oct-2021 05:57:30	[ERROR] Provider message:
build	04-Oct-2021 05:57:30	[ERROR] The git-tag command failed.
build	04-Oct-2021 05:57:30	[ERROR] Command output:
build	04-Oct-2021 05:57:30	[ERROR] fatal: tag '2.12.0' already exists

I’ve deleted the tag for 2.12.0.


thanks ian,let me release again

hi @ibacher it now breaks with Failed to deploy artifacts: Could not find artifact org.openmrs.distro:referenceapplication:pom:2.12.0 in openmrs-repo-releases,full logs

Your having attempted to release twice may have resulted into partially uploaded artifacts and the subsequent failing of the second attempt. I have cleaned it all up. Can you try to release again?

I have also noted that you have not yet released the reference application module. I thought you would do it before attempting to release the distro.

1 Like

ohh i see, and i had even spinned the process again of releasing the reff app,is there a quick way to stop it so that i release the reference application module first

a gentle request to help me revert the release i was trying to make and any existing tag of 2.12 so that i can first release the reff app module @dkayiwa

Tag deleted.

1 Like

a gentle request to also help me delete the tag for Reference Application Module cc @dkayiwa @ibacher

Which tag? Can you point to it with a url?

well on trying to release reff app module i run into

@dkayiwa and i had quickly read this line ERROR] mvn release:prepare failed, scroll up the logs to see the error. release:rollback was attempted. Delete the tag from the repository (if it exists), check if the SCM tag is a ssh and not http and try again.

@dkayiwa i am using this on releasing Reference Application Module - Reference Application Module Latest 3894: Build result summary - OpenMRS Bamboo

Could there be any thing that causes the breaking of the release of the module basing on the logs?