Proposal for Limited Scope RefApp 2.13 & request for Release Manager


@raff is this a side effect of your recent work on docker images for the reference application?

I’m looking into the issue… I’ll update you once fixed.

Fixed! The issue was that the release job was building an older version of an image (the one from SDK). Fixed to use correct Dockerfile and pushed to dockerhub.

1 Like

Thanks so so much! I have tested out and it works as expected.

Well! @ibacher, @raff, @dkayiwa, @burke am so glad the tough journey has come to an end. I will begin with the release announcement after sabbath tomorrow by God’s grace. Blessed weekend to all!

Hey @jwnasambu , i setup refapp2.13.0 using openmrs-sdk and everything was okay. However, when i tried starting it up after a couple of days, i am landing into this error that suggests that the atlast module zip file is corrupt → ERROR - ModuleFactory.loadModules(196) |2023-03-27T08:37:44,835| Unable to load - As can be seen in this screenshot. Screenshot from 2023-03-27 09-02-28

The omod looks corrupt and i needed to replace it, however i am not able to find that particular version of the atlas module (2.2.6) at OpenMRS Add Ons.

/cc: @dkayiwa @ibacher

I got exactly the same error while setting it up. It turns out that the release of version 2.2.6 of the atlas module was incomplete. I have just released version 2.2.7. Though even version 2.2.5 should work fine because there were no real changes between the two.

Thanks @dkayiwa for the help! Its unfortunate I haven’t done a followup after the release because of my poor health and I promise to do it when I get back to my feet. @mherman22 thanks for the point out.