Project not building

Tags: #<Tag:0x00007f828de734b8> #<Tag:0x00007f828de733f0> #<Tag:0x00007f828de73328> #<Tag:0x00007f828de73238>

I am getting the error in building the UI, I followed the steps as mentioned in the documentation. But I am getting the error and when the application is deployed, I am displayed that I will I have to install the UI.

Did you try building it from command line with mvn clean install?

Yes I did as it was mentioned in the documentation

Did it succeed building on command line?

Yes it did, it showed SUCCESS status for all modules

Then to run it, just switch to the webapp folder and do: mvn jetty:run

I have done that, ones it starts I’ll reply here

This is the second time, openmrs-core projects runs and the initial setup is done I am redirected to a page I am attaching here, and I have installed the user interface also.

Which user interface module did you install? And where did you install it?

https://wiki.openmrs.org/display/docs/User+Interface+Modules

I followed the instructions from above page. But as you might have seen in the image I had sent, the version number is also not parsed, and the error is also related to version number not getting parsed.

Just dump the legacyui module in the modules folder on your file system and then restart the webapp.

Did the same thing but was getting the attached error I have updated the settings.xml according to the documentation, but still getting the error

Which exact command did you run? And from which folder?

I change my directory to webapp folder, and I ran mvn jetty: run command

Can you paste the full log at pastebin.com? That is from the very line where you type that command up to the very end.

That command worked mvn jetty:run, but still I am redirected to this page in the screenshot

And this is the log while ‘mvn clean install’ the legacy UI, https://pastebin.com/JMMnZMqj

And this is the log after running ‘mvn jetty:run’ https://pastebin.com/kJ27Wmg5

Paste the legacyui module .omod into this folder C:\Users\atishaya jain\Application Data\OpenMRS\modules

Then run the command afresh.

Thank you, the login page opened. Now anything you can suggest me to start with, it will be helpful for me.