Problem with Drug CSV upload "Invalid Query"

In a recent implementation, I needed to clear out the entire drug database and re-upload the drugs. When I attempted to do so, it completed with errors with “Invalid Query” as a message for all the rows. The error was cased by “+” symbol as the only rows that throw the error have the plus symbol.

In order to check if this was not a problem with my file (relating to encoding or something else), I tried to upload the default files provided in the bahmni wiki article but that ended up throwing the exact same error in the rows where the plus symbol exists.

I was wondering if anyone has faced this issue before and if so how they managed to solve this. Please find the attached error file to get context on the matter.

drugs_fixed_2023-07-14_08 21 50.err.csv (5.6 KB)

@utsavdeshar @sudishrestha

I hope you have the generic name and dosage form as a concept uploaded before. Try uploading without it; if it works, you need to upload the concept for the generic name and dosage form and after then this file. Please note if the field is mandatory then you have to understand this rule before uploading.