Problem setting modulus development environment

I have been trying to setup my modulus development environment for some hours now and i am having issues. I Followed the instructions on the wiki. First i was having these errors when run grails refresh-dependencies, which with a bit of googling i fixed by downgrading from java8 to java7. Now i am having these errors with grails run-app. It seems to be a mysql issue so i have tried running grant all on modulus.* to ‘root’@‘localhost’ identified by ‘password’; but still get these errors. I have tried google but nothing.

I had a bit of a time setting it up myself. @elliott should be able to help you better than anyone

Currently you need ID Dashboard to work with it…I’m working on that…so you won’t be able to authenticate

Removing the password for mysql database has helped me. You can remove the password using the following SET PASSWORD FOR root@localhost=PASSWORD(’’); BTW OpenMRS installations don’t work after removing password as some checksums are changed Hope this helps you. :slight_smile:

@vishnurao thanks for that. But i am sure if i want to try that since i have a lot of applications depending on that password.

Agreed!. We should find any other way out.

We should be using docker to set up dependencies for everything, where the password is moot.