Problem doing Platform 2.1.3 release

Over the weekend I tried to do a release of Platform 2.1.3 to get in a small bug fix, but there were some failures when I ran the release component of the platform, see here:

It looks like the latest platform war was successfully deployed to Openmrs artifactory (, but was not copied successfully to Sourceforge (

And it looks like the standalone build failed completely.

I’m not sure if it’s actually necessary to release a new version of the standalone, but it would be good to get the war published to source forge. But since the release was partially successfully, I’m not sure what the proper steps to take next would be? I was contemplating manually uploading to source forge, but I don’t think I have the proper credentials.

Thoughts? @dkayiwa?

Thanks and take care, Mark

@darius @wyclif @raff fyi…

Also copying @cintiadr. Who has been the lead on configuring these CI pipelines?

The Publish Readme and war clearly are missing files on the agents. Quite possibly something I didn’t realise it was still being used, or something during the migration.

I will fix later today, and rerun the failed stages.

The release standalone is different. Not clear to me what happened, will check later.

From memory, I think @raff was doing some work on that release. I didn’t check the audit log though.

So, the publish failed because it was looking for the release scripts on the wrong folder (the checkout was on the current directory, not inside releases-scripts subfolder).

I think the release standalone task failed as the ‘-Dopenmrs.version’ option wasn’t configured. It’s running now. In theory we should know the result in 50 minutes (!!!).

… and the path for the standalone wasn’t correct. Trying again :smiley:

Woot, green :smiley:

Thanks @cintiadr!

I’m sorry It was my mistake. Thanks @cintiadr for fixing that!