Privilleges and ID auto generation

I have two questions, the first is about ID auto generation: Why I cannot create customized Identifier Type and set it to auto generate. I have created one Identifier type that exactly matches OpenMRS ID except in the name. and Once I add it to the auto generation option and remove the OpenMRS ID this error show : Validation error found (see picture below below). I tried it on demo server. it is the same result.

The second question is : What is the privilege that controls the new view button (see picture below)

Also, How can I prevent users from deleting/editing their own notes in addition to other users’ notes

Thanks very much

Can you set this up on qa-refapp.openmrs.org?

@dkayiwa Here it is … it is called TEST ID … try to register a new patient

https://qa-refapp.openmrs.org/openmrs/admin/patients/patientIdentifierType.list

Did you change “emr.primaryIdentifierType” to point to the new identifier type?

Nope… Where can I do that?

Some where like here: https://qa-refapp.openmrs.org/openmrs/admin/maintenance/globalProps.form

I understand… but what I meant is that it does not really say anything there (like a UUID or so). Here is the Value there This global property had been migrated to metadata mapping in source ‘org.openmrs.module.emrapi’ with code '&s’

If you are using reference application 2.5 and above, then check your database table named “metadatamapping_metadata_term_mapping”

@dkayiwa I ran a script for the database to changed the UUID. It does change the UUID. However, I am still getting the same error when I try to register a patient. On the database, I noticed that the value goes back to the original UUID if I restarted the server.
Any suggestions ?

Does it work well before restarting?

Nope… I think I found the code that might need changing in reference metadata. I will test that out.