Patient Identifier is not assigned for the patient in Bahmni connect

patientidentifier
bahmni-connect
Tags: #<Tag:0x00007fb858ec60e0> #<Tag:0x00007fb858ec5f28>

(Amol Chavan) #1

I am trying to configure Bahmni Connect 0.89 with location-based strategy (using Bahmni connect PWA and android app 0.89.166).

I have created patient in Bahmni Connect and this patient is synced with Bahmni online server.

On the Bahmni online server patient identifier is assigned to this patient:

On the Bahmni Connect patient identifier is not assigned to this patient:

What I have tried: Followed Bahmni wiki : https://bahmni.atlassian.net/wiki/spaces/BAH/pages/94535719/Server+Requirements https://bahmni.atlassian.net/wiki/spaces/BAH/pages/325713930/Setup+Bahmni+Connect+using+Location+based+sync+strategy

In the openmrs database In the event_records table uri column was null therefore I had deleted records from table event_records where category = ‘addressHierarchy’.

Inserted address Hierarchy into event_records table with following sql.

Insert into event_records(uuid, title, timestamp, uri, object, category) (select uuid(), ‘addressHierarchy’, ‘1970-01-01 00:00:01’, concat(’/openmrs/ws/rest/v1/addressHierarchy/’,uuid), concat(’/openmrs/ws/rest/v1/addressHierarchy/’,uuid), ‘addressHierarchy’ from address_hierarchy_entry);

After that, I have mapped once again address for login location in openmrs GUI. Added_address_to_login_location

While registering patient same address are captured.

Is any suggestions to resolve this problem of Patient Identifier not assigned in Bahmni Connect.


(Dimitri R) #2

From @angshuonline on Slack:

@amolsatvix sync the data and the patient will be allocated an identifier. if thats not happening, it can mean that the sync is not happing. check in the server if the patient can be searched by other attributes. basically, narrow down to figure out where the problem is, see the logs … both client and server


(Amol Chavan) #3

@angshuonline I am able to search patient in server by other patients attribute.

Server bahmni-event-log-service.log https://pastebin.com/WJu73MKp


(Angshuman Sarkar) #4

@amolsatvix - the logs are from the server. You will need to investigate the logs in Connect.

The fact that the server was able to handle the POST request and successfully create the patient meant that the POST request went fine. As part of the POST response, it sends out the identifiers as well.

You should check the connect logs to see why the response is not handled, the client side log should give you ideas. Few pointers:

  1. Is this replicable using Connect while used as PWA? The database is different (indexDB for PWA and SQlite for Android). If this works with PWA, you can narrow it down to Android version
  2. Debug through GenyMotion for Android

(Suman Maity) #5

Hi @amolsatvix,

Can you please check your event_log table? Also, check the filter for the device in the local_storage of android. You find it by connecting the device to chrome (laptop) and hit chrome://inspect


(Amol Chavan) #6

Hello @sumanmaity112,

Following is event_log table. https://pastebin.com/zMpTzTqz

In table event_log the filter column is empty for all category.

I am using PWA of Bahmni Connect. PWA local_storage filter


(Suman Maity) #7

Hi @amolsatvix,

Your event_log should have some filters. Please follow the given steps

  1. Stop bahmni_event_log_service

  2. drop event_log table

  3. Start bahmni_event_log_service

  4. Follow steps present here


(Ryan Mangahas) #8

@amolsatvix, is this same issue?

Have you solved it already my friend?