Patient Appointment Request Issue [RESOLVED]

When a Scheduling an appointment for a patient , when a user navigates to manage appointments and selects the patient, The appointment made before should be indicated appointment requests of the patient

However i have tried this on both local and online instances and the Appointment request is not registered . Unable to search, are your search parameters valid? is returned as below

This Test fails at this point

is there something being missed or its a bug @kdaud @sharif @dkayiwa

Hello @insookwa seems the test is closed .

@sharif its open but relates to this closed ticket

Can you share the server side log for the local instance?

@dkayiwa the logs are here

Can you share as well the stack trace provided by your IDE ?

@kdaud I actually have no ide running . was running from online instance

Run the test as a JUnit test within the IDE and share the stack trace the are thrown!

Hello @kdaud here are the logs with chrome

and with firefox

The logs are the same and are clearly showing that the test is breaking as a result of waiting for a certain element look up which can not be retrieved. You need to watch clearly the test when simulating to see exactly where things are breaking and you will be able to figure out the mess.

Ensure to set headless property value to false so as to observe the test leakage via UI otherwise you’re on track ← :biking_man:

Thanks, @kdaud however the way I think it is, after scheduling an appointment, when you come back to the patient, the appointment should appear under appointment requests and that’s what the test looks for which is not appearing.

which means the appointments are not being scheduled. because its the case even when i do it manually

Have you confirmed this practically ? Do you mind taking the simulation again and confirm ?

It’s doing the same even on the local instance.

Are you able to identify where the test is breaking from ?

@insookwa do you have some time we schedule a call to figure out the solution together for the test in the context ?

1 Like

Thanks @kdaud i am available anytime yo sugest

Hey @insookwa can we catch up on this ?

The causes for the failures on this issue were arising because I had not updated my repo with the master which led to failures on CI. Some changes were made in the logic too.

basically following this procedure

git remote add upstream
git pull --rebase upstream master
git fetch --all
git push origin master

There was a challenge of the IDE also reflecting changes in the whole code whenever we save. this was done by the formatter . i think there is something to fix with the OpenMRS guide on setting up eclipse. This was solved by using a fresh installation of the IDE . The tests later passed CI

Thanks to @kdaud for spending a number of hours with me fixing this

@insookwa do you mind taking a look into those settings stipulated in our wiki ?