Password Validation Error Message

First time user here. I have set up the 2.9 Reference System.

I was trying to add a new user account and I repeatedly got errors like this:

Validation errors found
Failed to save account details

I eventually dug into the server logs to figure out is pass a password validation error. Is this the expected UI? There must be a way for the end user to get a notification of what the validation error is, right?

Do you get the same error when you enter the same information here? https://uat-refapp.openmrs.org/openmrs/admin/users/user.form?createNewPerson=true

Yes, same behavior on the demo site:

Validation errors found
Failed to save account details

I did something liek… user: soandso pass: soandso123

To be clear, I’m not saying that the password requirements are bad – I’m saying the user should know what the requirements are, or which ones they have violated.

Can you share a screenshot?

It’s there in my first post.

Did you see the url that i posted?

Ah. The first time I followed your link I logged in and then went to administration through the menu and received the same error. This time I clicked on your link, and I tested it again and it gave me an appropriate error message:

 Please choose a password that contains both upper- and lower-case letters

So the user form and the account form have different UX here or what?

You can create a ticket for it.