PACS Integration service install process

I’ve been searching for the Bahmni PACS Integration Service install process in the Wiki but it is not there. Can someone please point me to the right place?

Thank you !

So I found an article on how to install both, Bahmni PACS Integration and DCM4CHEE. I used yum install -y dcm4chee pacs-integration and was able to complete the installation.

I noticed the services are not started automatically, so I started pacs-integration service without issues. However the dcm4chee is not starting, this is what I got after running service dcm4cheee start:

Starting DCM4CHEE [root@Bahmni clinical]# /var/lib/bahmni/dcm4chee-2.18.1-psql/bin/ line 217: /usr/java/jre1.7.0_79/bin/java: No such file or directory

It looks like java is missing on my CentOS server. Should I install it?

Thank you

Ok so I gave a step ahead and installed Java 7. When I try to start dcm4chee, it won’t start. I found a WARNING and ERROR entries in the boot.log file:

02:46:20,849 WARN [BasicMBeanRegistry] preRegister() failed: [ObjectName=‘jboss.remoting:service=NetworkRegistry’, (]

02:46:20,861 ERROR [MainDeployer] Could not create deployment: file:/var/lib/bahmni/dcm4chee-2.18.1-psql/server/default/conf/jboss-service.xml

Your assistenace will be greatly appreciated.

Hi @htorresb, can you please look at the permissions on /var/lib/bahmni and the inner folders.

Swathikarvala, this is what I found when I ran namei -l /var/lib/bahmni

f: /var/lib/bahmni dr-xr-xr-x root root / drwxr-xr-x root root var drwxr-xr-x root root lib drwxr-xr-x root root bahmni

Thank you

bahmni user should have access to /var/lib/bahmni folder and its contents. please use the below command to grant bahmni user permission.

Swathi, I tried that command but it didn’t work. Did you mean chown bahmni /var/lib/bahmni ? (which changes directory ownership to bahmni user).


Yes. Sorry chown -R bahmni:bahmni /var/lib/bahmni.

It didn’t work :sweat:. I created a new post with additional details.

Thank you