Ozone Installation Error

Hello Everyone,

I have now been greeted by another installation error. This one seems to deal with a maven dependency.

Here is a gist of the error:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-dependency-plugin:3.2.0:get (default-cli) on project ozone-docker-compose: Couldn't download artifact: Could not find artifact com.ozonehis:ozone-distro:zip:1.0.0-SNAPSHOT in temp (https://nexus.mekomsolutions.net/repository/maven-public) -> [Help 1]

Full Pastebin log: HERE



@achachiez @ruhanga when I see this:

Container ozone-docker-eip_client-1

I think we need to normalize the naming, it should be either ozone-docker-eip-client-1 or ozone-docker-eipclient-1. Could anyone of you take care of this for alpha.2?

@jack.carney2 what did you do exactly, what are the steps to reproduce the error you’re facing?

Hey there, @mksd! All that I did was execute sudo -E ./start-demo.sh, and it resulted in a build failure. This was a new Ubuntu VM environment.

When I search https://nexus.mekomsolutions.net/repository/maven-public/com/ozonehis/ozone-distro/1.0.0-SNAPSHOT/ozone-distro-1.0.0-SNAPSHOT.zip, it says it’s not found, which leads me to believe this is what’s causing the error.

@jack.carney2 what output do you get when you run docker version?

Docker Version 20.10.17

Ubuntu Version 20.04.5 LTS

Maven Version 3.9.0

OpenJDK Version 11.0.18

Docker Compose Version 2.5.0

And, I don’t know if you saw, but this warning also came up during installation:

[WARNING] The POM for com.ozonehis:ozone-distro:zip:1.0.0-SNAPSHOT is missing, no dependency information available
1 Like

This could probably be caused by the connection while running the plan. Could you try again?

I just tried it again, and it miraculously worked. I didn’t do anything different. Weird.

I am making a some changes on the docker compose project for alpha.1 so I will make this change as well