Order Entry OWA on RefApp 2.x >>Upload Error

The Order Entry UI App (1.2.5-SNAPSHOT) was built for production and the ZIP file created.

Next, the ZIP file was uploaded into a running 2.12 RefApp instance (core 2.5.8) using the Open Web Apps Module’s ‘Manage Apps’ utility & java.nio.file.AccessDeniedException error was encountered. The details of the error:

Full error log

Help needed! Thanks!

cc: @mogoodrich @dkayiwa


When the Stack Trace is followed further down it seems like the error is here

At this point, I feel an attempt is being made by Open Web Apps module to upload openmrs-owa-orderentry to the App Folder Path (the location where the OWA apps are stored) and write permission is being denied!

The App Folder Path on my system is /var/lib/OpenMRS/owa and the webserver has been granted all permissions on this folder.

I’m not quite sure about the way beyond this. Hope this gets sorted.


Are you able to successfully upload other open web apps?

To verify your suggestion, I just downloaded Cohort Builder OWA and tried to upload like before but ended up with the same error mentioned earlier.

Are you able to just manually unzip into the application data’s owa folder?

1 Like

Yes, that approach works. It’s now possible to see the App in the :

But it is not visible in the Patient Dashboard.

PS: I’ve also taken care of the additional cofigs mentioned in the Admin Guide like creating the Encounter type & role Global properties.

Are you referring to this? GitHub - openmrs/openmrs-module-orderentryui

No, this is the repo:

I guess on some of the WIKI pages there is some sort of an ambiguity as to which of the above two very similarly named modules they refer to :grinning:

Oh! I seemed to have missed something…there is an interdependancy between the two modules:

orderentryui is supposed to provide the UI functionality for owa-orderentry

But I’m facing a confusion now:-

At GitHub - openmrs/openmrs-owa-orderentry: Open Web Application for Order Entry it says:

Before using the Order Entry Open Web Application, First Load the orderentryui module into the OpenMRS instance , because it provides the Order Entry Widget on the Patient DashBoard used to acces the webb app.

But at GitHub - openmrs/openmrs-module-orderentryui it says:

This module has been deprecated in favour or Core Apps v1.28.0 + Order Entry OWA.

@nischith, if you are using Ref App 2.x with a recent version of the coreapps module, it is possible to use the orderentry owa without the orderentry module. See how you’d access the owa’s ui using the coreapps widget configuration Patient Summary Widget Documentation - Documentation - OpenMRS Wiki.

1 Like