Order Entry app won't start and redirect to Home page

I worked on a ticket RESTWS-706 then i wanted to pupulate the system and test. then

I downloaded and build the Order entry webapp using the instructions here at section Production build. installed it and when i launch it it redirects me to the Openmrs home page. I noticed just before the redirect it gives out a message saying If you see this text, look for an error in javascript console i looked at the console and just before the redirect it flashes the error uncaught (in promise) error failed with status code 404. full details of the error are on the short video attached.

Hi @harisu. The orderEntry app requires a couple of things to work.

  1. You have to append a valid patientUuid to the url when navigating to this OWA so that the final url look like http://localhost:8080/openmrs-standalone/owa/openmrs-owa-orderentry/index.html?patient=bcdb3329-7926-42c5-9c65-42e88ba3b386

  2. You have to setup encounterType global Property with order entry as it’s value and also create an encounter Type with value above as it’s name

  3. You also have to setup encounterRole configuration similar to step 2.

I understand the whole process seems kinda complicated. We are working on providing a more detailed information especially for anyone trying to use the OWA. You may share the omod with us for further testing if you please. Thanks

@larrystone Thanks i did with the patient Uuid in the url and it worked but the console error still remains and i can’t create an order after filling the drug order form the save button is blurred. here is the link to the omod file OMOD.

Okay, have you tried using the free text mode to create the drug order?
I and the team will look into the omod file and give feedback

cc @flavia @betty @geofrocker @zeze @fred

I’m sorry I have to ask. is this the omod generated from the RESTWS feature you worked on? I need to be sure so that we are not uploading the wrong omod as a replacement to the Rest Web Services OMOD. Thanks

@larrystone No that was the omod for the orderEntry app with the javascript error. Let me Re-build the Rest Web Service module just made some changes .

1 Like

@larrystone This is the link to the modified Rest webservice module https://drive.google.com/open?id=1KLw7G0iCG6WuS1D35E72JZmGly1QWStK

here is also the commit i made before compiling https://github.com/fanyui/openmrs-module-webservices.rest/commit/0cfe43f67924dcf6cfb157f6ac0ef04d0753c01f

Okay, we will look into and update you

Hi @harisu Thanks for the update on ticket you are working on.

The team would look into the issue you mentioned and give you feedback.

cc: @kodero @dkayiwa

@harisu The save button remains blurred until all the required fields are filled.