Openmrs_webapp failure in ubuntu

Tags: #<Tag:0x00007f6006c9b428>

i just finished installing openmrs and am getting this error kindly assist me solve the error

What do you mean by this

What output does mvn -v returns

Apache Maven 3.6.3 Maven home: /usr/share/maven Java version: 1.8.0_241, vendor: Oracle Corporation, runtime: /home/gilbert/jdk-8u241-linux-x64/jdk1.8.0_241/jre Default locale: en_US, platform encoding: UTF-8 OS name: “linux”, version: “5.4.0-71-generic”, arch: “amd64”, family: "unix

1 Like

Run git pull --rebase upstream master against the module and build again. Ensure your connection is ok.

hello @gilbert i see Already in use (Bind failed)<null>:8080 in the error logs which means the default port 8080 which the tomcat server uses is already in use so you can change the port by :

  1. Going to conf folder in tomcat installation directory
 e.g. C:\Tomcat 9.0\conf\
  1. Edit following tag in server.xml file
<Connector connectionTimeout="20000" port="8080" protocol="HTTP/1.1" redirectPort="8443"/>
  1. Change the port=8080 value to port=8081

  2. Save file.

  3. Stop your Tomcat and restart it.

thank you let me try this i will give you feedback

thanks let me try this

i still have the same error

have changed the port but still have the same error

drop the error logs in https://pastebin.com/

1 Like