OpenMRS Standalone doesn't run

(Sash Idd) #1

OpenMRS Reference Standalone

I’m almost a complete newbie to cmd, so this might be obvious. I have downloaded all the prerequisites and have been struggling to run OpenMRS. I get up to unzipping the download folder and the openmrs-standalone doesn’t run when opened with Java. After checking the documentation, it was clear that I couldn’t run it on java 1.8 (my version) without going through cmd, so I tried their solution on cmd - however I keep coming up with the error “the system cannot find the path specified”. For reference, here’s the code I used from the documentation (modified for my jdk): c:\Program Files\java\jdk-12.1.0\bin\java.exe -jar openmrs-standalone.jar

I tried to see if defining the directory to the openmrs file would work - this was the same. Any help would be greatly appreciated!

(Daniel Kayiwa) #2

Use Java 8 because we do not yet support Java 12

@mozzy @ruhanga this is why i suggested exploring support of newer versions for Java, to see how much effort would be required to do it in a backwards compatible way.

(Nathan Ruhanga) #3

Thank you @dkayiwa, there is a ticket in progress that captures this use case.

cc @irenyak1

(Irene Nyakate) #4

Thank you @dkayiwa and @ruhanga. Been trying out with openjdk 12 but all in vain and yet with Java 8 it compiles so easily.

FYI @mozzy

1 Like
(Sash Idd) #5

Thanks for the reply, I’ve discarded Java 12 and downloaded Java 8. I’m still facing the same error - it didn’t open via GUI, so I tried to open via cmd with pretty much the same code but I keep having the same error. Any further tips?

(Moses Mutesasira) #6

can i have a link to that documentation @raspbewwies??

(Moses Mutesasira) #7

@raspbewwies , now which version of java do you exactly have installed properly with the path variable properly set??

the latest standalone package we have now supports java8 , upgrading to java 12 is still under progress.

(Moses Mutesasira) #8

but also to note , java is perfectly backward compatible. actually a project built with java 1 can perfectly run with java 12. the only problem will arise from other libraries used.