OpenMRS Standalone Connection Error

I’m trying to run the OpenMRS standalone version 2.2. I’ve configured the properties file. I get this config error:

Each time the properties file reloads i see the default connection details: connection.username=openmrs and connection.password=test which are not the right details for my system. Is there anything I’m missing?

Does it already have data that you do not want to loose? If not, the easiest thing to do is delete the database folder and run it again.

@dkayiwa it’s a fresh openmrs standalone so when I run the ./run*.sh file i choose between two modes and proceed. but I get this error. I’ve deleted the database folder and still get the same error when I run again.

What is the name of the war file in your standalone? And what is the name of your runtime properties file?

Alternatively, you can just unzip to standalone again to a fresh folder and run.

@dkayiwa I see an openmrs-standalone.war in tomcat/webapps and the properties file is I have unzipped a new copy of the standalone and executed without making any changes to the *.properties file and still end up with the same error.

Can i look at your runtime properties file? I assume you downloaded this from the official openmrs downloads site. What Operating System do you have?

@dkayiwa I"m using Fedora 21, here is the runtime file:

Has it ever worked before? Or is this the first time you are trying it out on this computer?

@dkayiwa. It’s the first time. I’m used to the git clone but. it’s like the recent changes to the code base has broken the build so I can’t do any work. that’s why I want to use the standalone

@dkayiwa I downloaded the 2.2 zip file and unzipped. I did not get the war directly. Is that a problem?

I’ve just downloaded the war file and everything works now perfectly. It seems there’s a problem with the properties file in the .zip file.