openmrs sdk watch error.

I have just set setup a distribution instance with openmrs-sdk:setup 2.10 version of refapp and everything is working pretty well! However, after cloning openmrs-module-registrationapp to watch it with the openmrs-sdk:watch command I get this error of which I don’t know how to go about it.

Can you share the server side log?

Sorry for the delay response. These are the logs on the server side.

Does everything work well if you unwatch?

I run mvn openmrs-sdk:unwatch to unwatch but ended up with these error logs when I clicked on Register patient icon and these logs on the server side

What does this return? select property, property_value from global_property where property = 'registrationapp.started'

This is the output

C:\Users\JULIE>property, property_value from global_property where property = 'r
egistrationapp.started 'property' is not recognized as an internal or external command,
operable program or batch file.

It is an sql statement to run against your database.

When i run select property, property_value from global_property where property = 're gistrationapp.started'; I get Empty set (1.33 sec)

Your sql statement is different from mine. :slight_smile:

I have fixed just waiting for the output.

@dkayiwa am not seeing any changes on the terminal after entering the above command

Which means that the registrationapp is not running. Hence the No viewProvide named registrationapp error. It would require taking a look at the full server side log to tell why it is not started.

Thanks so much for the guidance.