OpenMRS Platform ${projecr.version}.${revisionNumber}.Running!

I have followed steps in this link https://github.com/openmrs/openmrs-core#deploy to download and deploy OpenMRS-core platform version 2.4. After I run:

mvn jetty:run The browser displays the following message.

To solve this problem, I have followed this link https://wiki.openmrs.org/display/docs/User+Interface+Modules just to install reference application and legacy UI. After that I run: mvn jetty:run This doesn’t work. Then I run: mvn tomcat:run Still the page: http://localhost:8080/openmrs-webapp/initialsetup displays the above error.

Any help is appreciated?

There is a PR to fix this. It should be resolved once it gets merged.

Edit: I misunderstood your question, sorry for that. Have you placed the modules in the appropriate directory?

@girma when you experience this it means some modules are not being loaded ,try free up some RAM space on your machine, re-start your pc

Am seeing your talking about platform version 2.4 ,try using platform 2.3 which has just been released then re-run jetty server again

Thanks

In which folder did you put the legacyui module’s omod?

@captaindavinci, Yes. I have placed the modules at (Windows + R > %appdata%>OpenMRS>Modules), and all the OWA files in my owa folder, and restart the web server as it is stated in this [link].(https://wiki.openmrs.org/display/docs/User+Interface+Modules) However, the problem is not resolved. What shall I do?

C:\Users\Admin\AppData\Roaming\OpenMRS\modules I have placed legacyui-1.5.0.omod to be the only module in this folder after I saw your comment in this [link].(OpenMRS Platform not running) This works fine, however, when I have added the remaining modules and start the server it displays an error. Please, help me to get rid of this problem?

Can you clear your browser’s cache, or press CTRL + SHIFT + R

@dkayiwa, I have cleaned the browser cache. Still, the problem persists.

Which problem?

1 Like

@dkayiwa, thank you for your help. Now I can see openmrs login page. Then, how can I add the remaining modules. Since legacyui-1.5.0.omod is the only module inside this folder: C:\Users\Girma\AppData\Roaming\OpenMRS\modules

You can download the modules/addons from here: https://ci.openmrs.org/browse/REFAPP-OMODDISTRO-9633/artifact

It is usually easier to use this: https://wiki.openmrs.org/display/docs/OpenMRS+SDK

1 Like

@dkayiwa, Thank you for the links. I have downloaded the modules/addons. After extracting I have added to the folder: C:\Users\Admin\AppData\Roaming\OpenMRS\modules Then I run the command mvn jetty:run to restart the webapp but displays this error. Error_Openmrs Startup-Short.txt (55.1 KB)

Can you show your error logs using https://pastebin.com/ ?

1 Like

Can you edit your post and replace the long error log with a link to pastebin that has your paste?

1 Like

Here it is: https://pastebin.com/uQxzisJs

Here it is: https://pastebin.com/uQxzisJs

Can you try using snapshot version of openmrs web services rest module, create its omod and then use it instead?

1 Like

I have tried a snapshot version of OpenMRS web services from: https://ci.openmrs.org/browse/REFAPP-OMODDISTRO-9633/artifact But still the problem is not resolved. It displays the above error as it is shown at https://pastebin.com/uQxzisJs Please help me to get rid of this problem.

Can you attach the snapshot version that you used? Where did you download it from?

1 Like

I have downloaded from the link that you provided for me, but it doesn’t work.