OpenMRS Platform not running

Tags: #<Tag:0x00007fdb7947f4f8>

hello everyone greetings, happened to setup my openmrs platform via Netbeans IDE and it ran perfectly however, after its installation (databases and user password in particular) it showed the screen bellow. what should i do next? regards

This shows that you have successfully run the platform. You can now install modules that you want. An example could be the legacyui or any other whose .omod you can drop in the modules folder before restarting the platform.

1 Like

i have tried that out but it bring back the same web page. i have also tried to clear my tomcat cache directory and web browser cache but its still bring the same interface. Read through and found similar issues which i discovered that its an older version that i cloned from git ie “openMRS 2.2.0-SNAPSHOT”. Is there any way i can get the link for latest version please?? Thanks

Which module did you install? And how did you install it?

1 Like

i cloned the openMRS code from git (https://github.com/openmrs/openmrs-core) as directed from the guide to my NetBeans IDE, installed tomcat 8.0.46 plus MySQL 5.7.19. Then i did a maven clean install, which later requested for gaols and i put “jetty:run”. it successfully started the server and i went to the browser to open up my openMRS webAPP. i followed the instruction as described in the tutorial by openMRS University on the initial setup which then led mi to that screen indicating “no user interface module installed”.

Did you see my post where i said this?

“This shows that you have successfully run the platform. You can now install modules that you want. An example could be the legacyui or any other whose .omod you can drop in the modules folder before restarting the platform.”

Yes i did see that… I cloned legacyui and built it within the openMRS core which then indicated on my IDE that some modules have been added into the api, web and webApp but on jetty run the same problem arose. Maybe I should be briefed on how I should add those modules please. Thanks

The .omod should be pasted into your modules folder. You can find that folder by checking the server log for a message which starts with: "Using runtime properties file: "

1 Like

By modules you mean the Api, web, webApp, test and tools.? Sorry to ask that but am new to the language thats why at times i find my self stack on the way. Cause I’ve found the .omod folder from the legacyui but now am a-bit stack.

Gilbert, I suggest that you try installing OpenMRS from scratch using the OpenMRS SDK. Once you have seen how this works (e.g. installing OpenMRS Platform or Reference Application, and adding modules on top of that) then you can try the manual installation you’re doing now.

-Darius (by phone)

1 Like

Hi Gilbert

It seems that you are facing a few problems while running OpenMRS. What I have noticed from the screenshots that you have shared, is that you are using a windows PC.

Typically when you try to install OpenMRS on a windows device, a few directories are created, in your hidden AppData directory. The default path is:

C:\Users<>AppData\Roaming\OpenMRS.

In the directory mentioned above you can look for modules folder. You can then paste .omod files, which can be obtained from here. Alternatively, you can clone these modules, clean install them using maven, and then paste the generated omod files to the directory ~\OpenMRS\modules.

1 Like

Hi @prateek thanks for your response and taking ur method first. according to my AppData directory, below is what am seeing in the openMRS folder, where do you think i should place the .omod files. thanks

@prateek i have tried placing the .omod files in the webapp directory but still getting the same problem. Maybe am missing out on which directory exactly to place those .omod files. Thanks

Check the openmrs log for a message which start with “Using runtime properties file…” This will show you the location of the modules folder.

1 Like

i have successfully found the modules folder and placed the .omod files there however, the browser brought the screen shot bellow. what can i do next? Thanks

Start with only one module in the modules folder. And let that module be legacyui

2 Likes

Thank very much for your kind support… It has successfully opened up showing the sign in tabs. And great thanks to all those who tried to offer there support as well. Thanks once against :blush::blush:

OpenMRS Platform 2.2.0-SNAPSHOT.0 Running! If you are seeing this page, it means that the OpenMRS Platform is running successfully, but no user interface module is installed.

Click here to access the Add On Manager and install modules

To learn more about the available User Interface Modules, visit the User Interface Modules wiki page for details about installing them

If you are a developer, you can access the REST API. (See REST documentation for clients)

http://localhost:8888/openmrs/owa/addonmanager/index.html#/

Adding the legacy ui module file at the following location fixed the problem of no user interface installed. /Library/Tomcat/apache-tomcat-7.0.92/webapps/openmrs/WEB-INF/bundledModules

Thank you. It works fine for me also. However, How can I access the remaining modules and play with the source code to add few modifications?