OpenMRS Platform is running successfully, but no user interface module is installed.

Application Name: Reference Application Version Number: 2.10.0

Question: How to view and use openMRS, it is saying “OpenMRS Platform is running successfully, but no user interface module is installed.” what I have done is I have downloaded the referenceapplication-standalone-2.10.0, then deployed the war file of openmrs in tomcat, then installed by doing advanced installation and below page is showing up. I have already visited https://wiki.openmrs.org/display/docs/User+Interface+Modules and put the legacyui.omod file in {Home}/.OpenMRS/modules/ folder but nothing happens, maybe I am doing something wrong…

Reference Application as a distribution consists of several other modules (bundled modules) working together to serve as EMR platform consuming the API implementation of OpenMRS Core .To install the standalone version, download the ZIP file and decompress it, then double-click the openmrs-standalone.jar file to run it. Besides that, ensure you are running java 8

Thank you for the reply. I am running java 11, so I want to know that the version greater then java 8 also work, right?

1 Like

It requires Java 8 as per the release notes

what happens when you try to restart tomcat after deploying the legacy ui?

then while accessing openMRS, the installation wizzard opens again

Does this happen on re -starting after you deployed the legacyui.module?

yes, after I place the legacyui.omod file at the required location in modules folder

by the way have you seen this https://wiki.openmrs.org/display/docs/OpenMRS+SDK ,installing openmrs with the sdk,you might actually find it easier for you

thanks @jwnasambu, downgrading Java from version 11 to 8 resolved my issue

1 Like

thanks @herbert24 for your suggestions

1 Like