OpenMRS Platform 2.5.0-beta Ready for Testing !

Hello Community ,

As we continue with the release process of the OpenMRS Platform 2.5.0 , I would like to let all know that platform 2.5.0-beta is now ready for e2e Testing ,especially the release features where possible .

Some issues were raised as blockers for low testing beta and I would like to clarify some points here.

I would like to therefore call upon volunteers , Implementations , distributions , squads and other parties to lend us a hand in testing out testing these features.

Platform 2.5.0-beta can be found here :

We still have the latest Refapp version (2.12.0) spinning on platform 2.5.0-beta at https://uat-refapp.openmrs.org/

or download it from Sourceforge

Key features to checkout include :

Download links at : For the Platform OpenMRS - Browse /prereleases/OpenMRS_Platform_2.5.0-beta at SourceForge.net

And Refapp 2.13.0-SNAPSHOT at OpenMRS - Browse Files at SourceForge.net

FYI @dkayiwa @burke @ibacher @anthony @ruhanga @omondi @ssmusoke @pih @ampath @MekomSolutions @grace @bistenes @angshuonline

@miirochristopher @herbert24 @kdaud @jwnasambu @irenyak1 @gracebish @sharif @christine @mherman22

@devnull @dev1 @dev2 @dev3 @dev4 @dev5

We will still use the spreadsheet used for Alpha

We have a limited time, and this phase and will be closing next week. Thanks in advance

3 Likes

@tendomart is there any difference at all between -alpha and -beta?

Yes , there was a slight change in the data model . There was a PR done by @pmanko following last week’s Fhir call ,And it was agreed it should be included .

1 Like

@mksd, are there any things you could test against Platform 2.5 with regards to your earlier request for making all collectable data entities properly form recordable? This doesn’t need to be anything ready for production; rather, simply exercising a prototype or trying out some code you later throw away would be fine… we just want to take this moment (with the 2.5 release coming in the next week or two) to make sure the implemented features meet your expectations.

These changes are now done in the Platform and should be available to you within the dev3.openmrs.org environment (or against uat-refapp.openmrs.org if you prefer to test there).

3 Likes

Hello @dev s, I am finding it hard to fully install tomcat 8 on ubuntu 20:04 LTS. I managed to install it and surely was able to see this test page here

However, just like that page says I have to install tomcat8-docs , tomcat8-examples and tomcat8-admin to be able to manipulate my tomcat using the gui.

The problem comes when I run this command to install tomcat8-admin. This is the error I get in the terminal .

Package tomcat8-admin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'tomcat8-admin' has no installation candidate

I was able to come up with the running portion of tomcat with the help of this post Is there any workaround that you could suggest for me ? cc @dkayiwa , @ibacher , @ssmusoke @kdaud @tendomart

Thank you.

1 Like

@irenyak1 you need to install the tomcat8-admin .

It’s the one that will give you access to the feature for deploying and running the application

or follow the instructions here . Compare Revisions · GIScience/openrouteservice Wiki · GitHub

I also faced challenges on Ubuntu 20.04 ,for tomcat 8.x

or you can try this

sudo add-apt-repository universe multiverse && sudo apt update then try installing again.

1 Like

First of all, thanks a bunch for this! This was a great example of the Platform team being reactive and getting in the box a really good low-level API feature.

Now in terms of testing it, that’s going to be a little complicated for three reasons:

  1. The scope of it that we were already using (Condition being form recordable for example), well is already being used for a while.
  2. The scope of it that we aren’t yet using (other entities) will need to find their way into AMPATH Forms and will actively be tested then.
  3. The most ready form engine to go through the testing exercise that you suggested is HFE, and again it only leverages the form recordable ability for Obs (I “think”) and Condition (yet again) :-/

@irenyak1 did you succeed ?

Not yet @tendomart. Still having errors. I seem to have set up my tomcat.service well but when I run

sudo systemctl start tomcat

I get this error

tomcat.service - Apache Tomcat Web Application Container
     Loaded: loaded (/etc/systemd/system/tomcat.service; disabled; vendor prese>
     Active: activating (auto-restart) (Result: exit-code) since Fri 2021-11-12>
    Process: 132615 ExecStart=/opt/tomcat/bin/startup.sh (code=exited, status=2>

here is my tomcat.service

[Unit]
Description=Apache Tomcat Web Application Container
After=network.target

[Service]
Type=forking

Environment=JAVA_HOME=/usr/lib/jvm/java-1.8.0-openjdk-amd64
Environment=CATALINA_PID=/opt/tomcat/temp/tomcat.pid
Environment=CATALINA_HOME=/opt/tomcat
Environment=CATALINA_BASE=/opt/tomcat
Environment='CATALINA_OPTS=-Xms512M -Xmx1024M -server -XX:+UserParallelGC'
Environment='JAVA_OPTS=-Djava.awt.headless=true -Djava.security.egd=file:/dev/./urandom'

ExecStart=/opt/tomcat/bin/startup.sh
ExecStop=/opt/tomcat/bin/shutdown.sh


User=tomcat
Group=tomcat
UMask=0007
RestartSec=10
Restart=always

[Install]
WantedBy=multi-user.target

Will get back in a while.

What do you get when you run this

sudo /opt/tomcat/bin/startup.sh

@irenyak1 You might get some more valuable information by running sudo journalctl -u tomcat. That should show you whatever output came from trying to run the service.

2 Likes

Hello @ibacher and @tendomart I have tried running the command and this is what I get

So have you tried to restart the server ?

my /opt/tomcat is empty there’s no bin folder in it

It could be in some other place like under the /usr folder

@irenyak1 If you followed the instructions from that post, the shell scripts you need will bin in /usr/share/tomcat8/bin, so you’ll need to update ExecStart and ExecStop in your service defintion.

You’ll also want to change CATALINA_HOME to point to /usr/share/tomcat8 and CATALINA_BASE to point to /var/lib/tomcat8 (which you may need to create an ensure that the tomcat user and group owns). Finally CATALINA_PID should be /var/run/tomcat8.pid.

2 Likes

@irenyak1 any progress on this ?