OpenMRS Maintenance Mode Page Redirection Issue

I’m using OpenMRS Platform 1.11.4 along with Reference Application 2.3.1 as my development environment.

When I make changes in liquibase-update-to-lates.xml and start the tomcat server, it runs in ‘maintenance mode’ as expected.

The issue is that after applying the database changes, the browser redirect to http://localhost:8080/mrs/login.htm with renders as a blank page with error This localhost page can’t be found.

The server logs shows the following warning: WARN - DispatcherServlet.noHandlerFound(1101) |2016-12-12 11:42:42,143| No mapping found for HTTP request with URI [/mrs/index.htm] in DispatcherServlet with name 'openmrs'

Note: When I restart the tomcat container again, it successfully deploys the application and I’m able to access http://localhost:8080/mrs/login.htm without any issues

To verify, you’re running into a one-time issue, the first time load code with custom changes to liquibase-change-to-latest.xml, but after the first time, things work correctly?


Exactly @darius. It’s a one-time issue and happen every time I add a changeset to liquibase and restart the server.

Does this happen with when you do not have any custom modules?

I run into the same issue when I do not have any modules and run tomcat with just the platform war file.

@themoonraker13 which version of the platform war file?

OpenMRS Platform 1.11.4

Can i look at the error you get on using the platform war file without modules?

The same error which I got while running platform along with modules.

Are you able to reproduce it with platform 1.11.7?

@dkayiwa I am deploying 1.11.7 and just got the same error. I however have a bunch of modules (for Kenya EMR) deployed as well. Did you find a fix?