OpenMRS Form Entry Module

Application Name: OpenMRS Version Number: 2.1.0 Question:

I have successfully setup OpenMRS. In patient information section, there is form entry section. I saw form entry module is missing. In the Administrator-> Manage Modules. I have installed the Form Entry App for OpenMRS 2.x. But still i can see the same neutral error “Your administrator has not installed an updated form entry module”. In addition, I have also intalled other dependent modules. The following screen shows the modules and the neutral error.

I have tried restarting the maven server. but still no luck. In addition, there are two more form entry modules

  • Form Entry
  • HTML form Entry

I also tried these but it was throwing link errors, I think those are not for OpenMRS 2.x. Is that correct? Then why Form Entry App Module is not working Any help would be appreciated

The form entry modules that the message is telling you about are actually the XForms module and the HTML Form Entry module.

What you have installed (Form Entry App) is for the Reference Application, whereas you are using the Legacy UI.

I would suggest that you take a look at the Distributions page, which lists some ways to get OpenMRS that are more pre-packaged.

Actually, I am working as the developer, so I have setup everything on eclipse and I am using maven server. I downloaded the OpenMRS core and imported in the eclipse project, which is working fine. In addition, I installed Legacy UI to interact with OpenMRS. Initially, I want to familiar myself with service layer and database layer. So I am reading the documentations and API structure for OpenMRS wiki. I hope this is the right way I am analyzing this two layer programmatically.

In addition, I just installed the XForms. The module installs perfectly but when I open the patient information it throws an exception.


On the console it says the X forms table is not there in the OpenMRS database. I checked its not there. The question is if OpenMRS is modular in design then why the table is not there for XForms ?

Also, the xForm module is successfully installed. In the administration settings if I open the design page.

Its saying it couldn’t find the DWR class. How come its missing since I have installed a .mod file

This means that when you were installing the xforms module, it go problems why trying to create the tables. Can you paste the full tomcat log contents at

Hey Dkayiwa, I am assuming there is something wrong while executing this file ( I have pulled the source code from GitHub for the XForms module and I generated my own mod file and installed but still, the problem was same. Then I manually created by copying the queries from the above GitHub link. Now my problem is fixed by manually creating tables. I am wondering how we can fix this module?, how can I check what goes wrong while installing this module. Yes sure here is the tomcat log (

There are two kinds of errors

  1. one is table not found (which is fixed by creating table)
  2. SQL grammar exception (Which is also fixed by creating table)

UPDATE: Dkayiwa, Initially when I installed this module, there were no errors in installation of module completed successfully. However, there were errors which are presented in my last comment.

I mean the tomcat log for the very first attempt to install the module. That is when the table creation failed in the sqldiff.xml After looking at that, we shall be able to tell exactly what led to its failure. You could try drop the database, delete the runtime properties file and install the module afresh. This will give you the fresh failure log with the root cause.

I am sorry, I couldn’t reply my whole dev envorinment was crashed. I think the problem was in the installation the module is working fine.

Hi Dkayiwa,

I was able to create the same problem, here is log ( when we first attempt to install the module. Problem is there is no table related to xforms in database.

@emysa341 can you try version 4.3.11 of the xforms module?