OpenMRS error doesn't go away

I got this error after refactoring/renaming one controller in my code. So I reverted it back, and uploaded it in OpenMRS and it still showed the error. I tried to delete the class instead and uploaded it in OpenMRS, and it still shows the same error.

Does anyone have any idea why this happens, and how to resolve it besides doing a fresh install?

Controller for which module? After reverting your changes in the module, what exact steps did you take to ensure that openmrs is using your reverted version?

A controller for a module that I made. After reverting the changes, I just built the module in eclipse to produce an new .omod file and replaced the one in my “.OpenMRS/openmrs/modules” folder. I restarted tomcat to see the changes, but apparently, it still sees the controllers even if I already deleted them?

After that, I tried a fresh install of the OpenMRS. I undeployed it from my tomcat, dropped the database, deleted the “.OpenMRS” folder and tried to install it again. I built my module, and once I uploaded it, it still showed the same error, even if the file “ITRController” or “AnthropometricDataController” doesn’t exist anymore.

Is the module source anywhere like on github? If not, can you just share with us the compiled version of the module?

Try doing a project-wide search of text “ITRController” in your module code.

1 Like

I got it! Thank you!