openmrs-core test failure

Tags: #<Tag:0x00007f751bd55010>

Hello community;

I have been doing a mvn clean install in the core for hours now in order to respond to a couple of comments that were raised on some trunk tickets minus making any changes in the code and am getting this error , even after cloning the core afresh and wiping my m2 folder to begin from scratch i still get the same test failure when i build in the core(master branch) without making any slight change in the code.

Asking for help on what could be the cause on this error

@dkayiwa @samuel34 @mozzy

you could first try to pull the latest changes then do a fresh build

i did that with a fresh clone but still got the same error,

Maybe you can try to build on your local core and see if your able to get BUILD SUCCESS?

@gcliff If you are using linux os, ensure you run the command as a super user

I’d strongly, strongly recommend that you never run maven, git, or anything like that as root. If you have permission problems, it’s better to fix the folder permissions than doing that.

1 Like

@gcliff, are you able to run getPatients_shouldIgnoreAccentsWhenMatchingName from your IDE? Eclipse or whatever.

Also make sure to show the java version you have.

yes @cintiadr i get success in the IDE when i run the PetientServiceTest class that has the test method

java version is “1.8.0_191”

@cintiadr @mozzy @irenyak1 @jwnasambu @dkayiwa

has any one tried to build their local instance and come across this test failure ?

Hi @gcliff could you re-run Maven with the -e switch to see the full stack trace of errors.

yes i saw the full stack trace but it seems to be an issue with windows

@dkayiwa @wyclif @mksd am kindly asking you for some thoughts into what could be the cause of this particular test failure https://pastebin.com/6j29aUsy with a fresh clone of the core, updated it & built…

yet the same test passes when “getPatients_shouldIgnoreAccentsWhenMatchingName(org.openmrs.api.PatientServiceTest)” is run in my eclipse IDE

Did you do what @irenyak1 told you to?

yes i did run mvn -e to get the full stack trace but i wasn’t able to fully understand the error , i did report back to her claiming it to be an issues windows…

I also shared the error logs in pastebin

Was that privately?

No,

when u scroll back up in this talk thread a few minutes back i did respond back

Did you share the log of what you got as per her instructions?

let me share them here for @irenyak1 to have her insights into the stack trace

Are you sharing the correct log?

yes @dkayiwa they have the everything from a fresh clone, to the build and finally to the tack trace after the build failure

Which command did you use to compile?