Openmrs Core has tests that fail

i compiled openmrs core and ran some test and 2 of them failed . The test that fail are in OpenmrsUtiltest. Is this wanted or this should be fixed? Can someone confirm that these fail too for them ?

Do you have any local code modifications?

No. I just imported and tested if the tests pass before to add anything else.

  • Are you able to share the full log via pastebin?
  • Be sure your running the latest changes. -> git pull upstream master then git reset --hard upstream/master

You mean this

Also i have latest version of master.

From where are you running these tests? Terminal/IDE?

IDE , intelj idea . I worked at openmrs rest and didnt have any problem. But now some tests fail from first run in opemmrs core.

Can you run from terminal with mvn clean install and tell us what happens.(You paste the full log again) failed

Use Java 8

I tried but nothing has changed . I see that the log tell me that is not found . I tried to find it in mvmrepository but i cant look: Is something that im missing?

also can check this

What does java -version return?

java version “1.8.0_191” Java™ SE Runtime Environment (build 1.8.0_191-b12) Java HotSpot™ Client VM (build 25.191-b12, mixed mode, sharing)

What does this command return? mvn -v

I solved the problem. Maven I installed maven 3.6 and now the tests works. Thanks